3D Mouse stops working when switching from Sketchup to Layout

Whenever I “File > Send To layout” the 3d mouse stops working.
Also if I have both programs open and switch from Sketchup to Layout the 3d mouse stops working.
I have to open the 3d connections widget settings to get it going again or restart Sketchup, but as soon as I touch layout in anyway it stops working.

I am working on a PC 64 bit, windows 10 with a 3d connections spacemouse compact.

I have uninstalled and reinstalled the 3D driver
I have uninstalled and reinstalled SKP
Restarted the computer several times
Threw a little temper tantrum and cursed at it, still nothing.

Has anybody else experienced this and figured out a solution?

1 Like

When you installed or reinstalled, did you reight click on the downloaded installer and choose Run as administrator?

Are you using the latest SU2019 version?

I’m kind of surprised that didn’t do anything. Are you sure you were holding your tongue right? :slight_smile:

Is it in SketchUp that it stops working? Do you have the latest drivers from 3D Connexion?

Yes, right click run as administrator in the only right way :stuck_out_tongue_winking_eye:

I do have the most recent version of the Driver
and I am as well totally surprised a little strong language didn’t have more of an effect on it :joy:

Yes it is. :wink:

Have you threatened the 3D mouse with a sacking?

By the way, I want to know if you provide pencils to play with while sitting on your Group W bench. :crazy_face: :rofl:

I may try threatening with a sacking next, I really love the experience and work flow of the 3D mouse but super disappointed in how buggy it is and the lack of any further development from 3D connections.
Yes I always provide crayons, and colored pencils for the Group W Bench :wink:

Because the spacemouse requires a plugin to make it work in SketchUp, LayOut isn’t actually supported as far as I know as it is not open to plugins and therefore there is no plugin for the “official” use.

I have experienced limited functionality within LayOut in the way of panning and zooming quite consistently in the past. When it does work the active program for the 3d Connection app shows as “Windows Explorer”. So, if the mouse doesn’t do anything in LayOut, bring up a Windows Explorer window over the top and then bring the LayOut window over the top again. Usually this kicks the mouse into gear for me.

I’ve seen a number of reports of users enjoying their 3D mice but I’ve never gotten into it when I’ve tried them. I also use SketchUp on a bunch of different computers and wouldn’t always have access to a 3D mouse. Consistency is important.

“What’d you get?”

“I didn’t get anything. I had to pay $50 and pick up the garbage.”

Thanks I’ll play around with that and see if I can develop a workflow. I even if a program doesn’t support the 3D mouse I wish it wouldn’t kill its use in the already open program.

1 Like

Best line in the whole song!

1 Like

Has there been a change of drivers lately? If so try rolling back to the last one.

Agreed. Might be worth contacting 3D Connexion’s Customer Support.

Also agreed.

Unfortunately the roll back broke the mouse completely and it wouldn’t do anything except pan up and down

same here on su2020. Maddenining!

let me know if you figure this out. It only started for me after using su 2020

actually just tried su 2019 and as soon as i use layout it stops working. I have wireless and wired space mice. But don’t remember this being a problem before loading su 2020.
I don’t have this problem on my laptop which doesn’t have 2020.

I don’t know how the 3D mouse does its thing, but I wonder if it sets up Windows to know how to drive SketchUp, and then continues to know how to do that until you reboot. If it does work like that it would be possible to run a version of SketchUp that worked ok, then quit and run a version that doesn’t know how to handle the mouse, but yet it succeeds for a while.

Short version of that, can you look in this folder to see if there are any folders?:

C:\ProgramData\SketchUp\SketchUp 2020\SketchUp\

If there is plugins, or Plugins, are these files in there?:


1 Like

Hi Will,
I ended up not getting it to work, and since I had recently bought it, I just returned it. It was full of problems outside of layout as well. While the driver was installed many programs loaded sluggishly. Microsoft word took almost 3 minutes to load. As soon as I uninstalled their driver my whole computer ran fast as a rocket and most programs load in a second or two.

I was also disappointed that it does not work with may other design software like Adobe Illustrator. It does work with photoshop 2019 but has not been updated to work with 2020. (supposedly their is a work around)

I tried to get additional help form their forum, but it appears that you can’t post to it unless you where a member before they decided to stop caring about customer service.

After talking with their supports staff who where very nice and responded quickly, it became apparent that they do not have the relationship with other software companies like Adobe to get access to their development specs to further develop their product to work with other programs and they had no clue as to why their product is so buggy in general.

Below is what the their tec told me to do to fix the layout crashing problem. This did not work for me, and only made things worse, it took away the advanced options in the settings menu. I had to uninstall and reinstall the driver to get them back.

Good Luck, Like I said, in the end I decided to return it. It’s a good concepts, and was great to use when it worked, but I don’t think 3D connections has the resources to make it a good product.

Here is what they said
Try the steps bellow.

  • Navigate to C:\Program Files\3Dconnexion\3DxWare\3DxWinCore64\3DxDiag

  • Run 3DxDiag.bat

  • You will get a small window for our Diagnostic Tool.

  • Make sure its not displaying in Red that the log is not enabled. If its showing then please click on Enabled log

  • Once that done, Scroll down under Reset

  • Click on Reset driver settings then press OK to delete files.

  • Once that done, click on the second reset button which is Reset Configuration and press OK to delete files

  • Once that done. Test it

Thanks so much for the info and sharing the experience you had with the space mouse.
I have been using one for many years and can’t work with out one.
But with each update to sketchup there is an issue with the drivers.
I spent the whole weekend trying to figure out the issue(removing and reinstalling sketchup and the 3d drivers) and am pretty sure its the last driver update.
I rolled back to the previous one and didn’t have the switching to layout issue. But as you mentioned it only pans and zooms in 2020. I am at least back on su2019 with it working and suspect they will reissue a new driver to work with 2020. Hope you reconsider the space mouse as over the years its save me countless hours as well as an enjoyable work flow when its working properly. There is also a bug a saw on the forum about the model flying off into space that i’ve had as well that hopefully will get fixed.
Thanks again for your feedback