Sketchup Ruby Debugging with RubyMine


#1

Hello, Im having a problems setting up RubyMine’s debugger for use with Sketchup
I’ve been following this guide to help, however I have got no joy.

Upon Launching the debugger, the event log displays:
13:04:39 Error running Sketchup Debug: Cannot start process, the working directory C:\Program Files (x86)\JetBrains\RubyMine 7.0.2\jre\jre\bin"C:\Program Files (x86)\SketchUp\SketchUp 2014" does not exist

And Sketchup continues as per usual

Config is as below? Lost and confused on this one - As ruby (in general) isnt my main language i am unfamiliar with many of the things associated with it.

(note, was going to upload 2 photos, but apparently new users can only upload one?)

Fairly sure this is correct as per the guide, but still does not execute/debug correctly


#2

Hmm… that looks odd.

Have you tried without the quotes in the Working directory field?


#3

I have - it brings up the same issue


#4

How is your other setting for Remote Debug set up?


#5

the Run/Debug Configurations?

– Note

Unknown external tool is actually the Sketchup tool -


#6

Hm… I don’t really know. Have you tried setting a different working directory for the tool that launch SketchUp?
It’s strange that you get that mangled path. Maybe contact RubyMine support?


#7

It looks like you are missing a space in the path:

C:\Program Files (x86)\JetBrains\RubyMine 7.0.2\jre\jre\bin\"C:\Program Files (x86)\SketchUp\SketchUp 2014\"

Should be:

C:\Program Files (x86)\JetBrains\RubyMine 7.0.2\jre\jre\bin\ "C:\Program Files (x86)\SketchUp\SketchUp 2014\"

But really, there are 2 paths there. Should there be only one “working directory”?


#8

There shouldn’t be this compound path - the RubyMine path doesn’t belong here. I don’t know where or why they get combined.


#9

@jim_foltz - The path is being scrambled by RubyMine somewhere. The WD should be set to just the Sketchup bath

Thankfully, I can debug using the old “puts” method for now, but I noticed your article and decided to give it a try. I suppose it could be getting it confused with RubyMines working directory? I dont know? I’ll keep trying different things for now and hope i stumble accross something

Cheers Fellas!


#10

The RubyMine support team is really responsive - I’d recommend poking them to see if they understand what is going on.
Either that or try once more to go through the set up step by step.