Sketchup refusing to open a file because it is in Explorer


#1

I have this problem quite frequently. I never go anywhere near Explorer with any of my files, so what is going on?


#2

Check file properties with explorer and see if it is blocked. If you download a zip file doing this step unblocks all files in the archive other wise you may have to do it for each file.


#3

How do I do this? I can find no reference to properties in S/U or explorer


#4

It might be the known problem where you get the “File in use” error when the Preview pane is enabled in Explorer. Explorer in this cases refers to Windows Explorer, the application that you use to view your files and folders, not Internet Explorer.

Anssi


#5

You say ‘File in Use’ error. Is this another bug then?


#6

right click on the file ,using windows explorer , at the pop up drop down at the bottom will be a properties button, click on that a pop up will show with an advanced button , in some cases there also shows an unblock button depending on the source of the file. If it is a zip file unblocking it will affect all files in the archive other wise you may have to unblock each one.


#7

Thanks. BTW: I’m assuming that right clicking automatically uses Windows Explorer? I wouldn’t know how to do anything else myself!
Anyway, the various sub menus did open, but there was nothing in the advanced window relating to unblocking. This particular model is not a troublesome one, so do I take it that unblock and so forth only appears if there is a ‘problem’ with the folder in question. In other words: that’s why I didn’t see that option.


#8

You are correct and one will usually see if file is from external computer , it is just part of the security permissions.


#9

No, it’s still doing it! I’m currently trying to remove a load of redundant files from my USB stick, but it is proving impossible. When I click on them (and visit properties, as advised) I get three boxes: Read-only; Hidden and Archive, all are un-ticked.
The blurb reads:…“The action can’t be completed because the file is open in Windows Explorer”…
This is clearly a bug, so what can I do about it?