Sketchup Pro 2021 Installed but won't Run

MacOS X 10.15.7 Today I purchased a subscription to Sketchup Pro. I downloaded it and ran the installer. It seems to be be installed. When I double click to start, no windows appear, nor any menu bars. When I hit Cmd-Option-Escape to get to the Force Quit window, the app shows in the list as if it is running, but there is no user interface visible.

I followed the installation instructions carefully. I have also downloaded 2020 and 2019 versions, installed them, and have the same issue.

Any assistance would be appreciated.

Sorry it’s macOS 10.15.7.

Can you check for a message from me? It will show up as a green colored number attached to your avatar in the upper right of the forum page.

Colin is the MAN!

The solution was to get SketchUp running as an Admin user, then to copy the application support folder to the non-admin user account.

hi R121
how do you do that please - I’m having similar problems…
thanks
E

Rfrazier121 was the first case where I had seen this combination of issues. In his case he had a non-admin user that failed to open SketchUp at all, but when logged in as admin, SketchUp ran ok.

I had him sign in as admin, run SketchUp to the point that he was signed in, and everything was working ok, then copy the ~/Library/Application Support/SketchUp 2021/ folder to the Shared user. After that he logged in as the non-admin, copied the folder from the Shared user, to ~/Library/Application Support/ (which would be the non-admin user’s support folder). After that, SketchUp ran ok on the non-admin account.

appreciate that Colin - thanks
E