Sketchup Pro 2015 in High Res

When running Sketchup in full screen the screen goes black for several seconds or is jittery. It happens mostly when manipulating objects, but even when the image is stagnate it will go black. Also, sometimes the video signal is lost all together, with a message “Display does not support the resolution”. These problems only occur when running on Full Screen mode on this computer. When we run it in a smaller screen no problem, When we drop res to 1920x1080 full screen is fine. However, when we drop down to 1080 the image quality is horrible and cant show that to customers. We do not have any problems with other applications such as Revit and Autocad. We have tried disabling cross fire, which had no impact on the issue and disabling HW acceleration at the application, which had no impact on the problem. There are no errors in the windows logs. Tech support wont help me because we are running boot camp. So any thoughts or config changes are appreciated.

Computer: Mac Pro running bootcamp with Windows 8.1 64 Bit
Video Card: Dual AMD Fire Pro D500 (Fire GL V)
Video Driver:14.301.1010.0- Most Recent
Screen Resolution: 3840x2160
Skethcup Version: Sketchup Pro 2015 v.15.2.685 64Bit
Processor: Xeon 3.50Ghz-6 core
Ram: 32 GB

have you compared running the same file from SU [mac version] running on the ‘mac’ partition?

if the problems are the same, then ‘tech help’ would be available…

just a thought…


When you run on Windows, you would have to check for issues with the AMD/Windows graphic driver stack. Maybe it is improved in the latest driver versions?

By full screen, you mean maximized (because SketchUp has no full screen) or do you use an extension or external software to achieve this?

Also, believe me, if you well entertain your customers, they often don’t notice the difference between 1.0 and 2.0 pixels. They often don’t notice a lot of other things as long as they see what they want to see.

The fact that disabling HW acceleration and Cross Fire makes absolutely no difference suggests that Sketchup isn’t even using your graphics card. I had to manual set sketchpad to use my graphics card over my integrated GPU in my graphics card settings. Not sure what AMD’s equivalent is, but for me it’s “Nvidia control panel”.

Edit: Forgot we aren’t in 2015 anymore!