Sketchup Make 2017 not working after uninstall of 2016


#1

I had both Make 2016 and 2017.1.174 up and running fine on a 64-bit Windows 10 Pro system. I used Revo Uninstall Pro to uninstall 2016, which included a moderate scrub of the registry and left-over files. I looked at those steps carefully, and they only touched 2016-related items. Then went to open a file in 2017 and it crashed with an error report. Rebooted and tried again, same result, Did a Make install/repair, same result. Did a Make uninstall and re-install, same result. Did a Revo Uninstall and scrub on 2017, then reinstalled. Same result. What happens after a fresh install, is that I get the initial windows up to the point of specifying the template, and then nothing. Sometimes I’ve gotten a bugsplat, but most recently, I’m not even getting that. Scattered through there at reasonable points have been system reboots.

Any suggestion on what next, other than to go back to 2016 - assuming that will work?

I see there have been problems with video drivers, but 2017 was working fine before I uninstalled 2016.


#2

Disappointed that there have been no replies on this problem …

I did just run Sketchup 2017 Checkup and got these results:
Results:

Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.

Congratulations, your computer has met all the minimum requirements to run SketchUp 2017.

But Sketchup Make 2017 still won’t run.


#3

Could you try un-installing SU 2017 and then re-running the installer as admin (right-click, select Run as Administrator)?


#4

Thanks …Did what you suggested and it hasn’t made any difference.

After specifying the template to use, it just goes away. Not even a bugsplat.


#5

Any identifying characteristics on bugsplats you submitted?


#6

g…m@sb…

Will that work for you?


#7

OK, I PM’d, it’s an MFC crash, and we’re pondering the Visual C++ and Microsoft .NET installs.


#8

Thanks for diving into it.

Just FYI, I looked at the Registry values for .Net (per Microsoft instructions), and it wasn’t clear to me that 4.5.2 was installed, so I downloaded the Microsoft install package for that, and on running, it exited and said it was already installed.


C++ Runtime Library error
#9

On my further reading, I’m pretty confident it is the Visual C++ stuff, so download and install that, and if it’s there, uninstall and re-install.


#10

Can you give me a link for the right C++ package?


#11

YES!!! I found what looked like the correct link for VC++ 2015 in another thread, ran the install, it came up with the options of Repair and Uninstall. I did the Repair, which then required a reboot, and now Make 2017 seems to be working fine.

Thanks VERY much - in the few days I used it, I noticed it’s A LOT faster at loading and rendering files.

Probably worth a look at what it was in the uninstall for Make 2016 that broke the VC++.


#12

Oh - for anyone else with this problem and reading this thread, the VC++ link that worked for me was:
https://www.microsoft.com/en-US/download/details.aspx?id=53840


#13

thanks this help me and my problem is now fixed