Sketchup Make 2017 Mac OS Big Sur Dimension tool text up side down?

As an Apple share holder I sure hope that’s good news for them.

It would be nice though if Apple’s OS changes didn’t break applications, though. SketchUp 2019 had a late year update because a Mac OS update broke things. I believe SU2020 also had an update due to Mac OS changes. And it’s easy to think that maybe 2021 was released earlier than previous versions partly because of the changes with Big Sur.

It’s problematic, but I don’t see that much in other software. Now, I follow the development of Blender closely by regularly downloading the Alpha versions, which are not primarily developed for the Mac, and I am amazed by their stability. I use softwares which has not been updated for several years (admittedly, without OpenGL functions). Frankly, if there were so many issues with apps, I would have switched to PC.
I recently switched to Rhino7. Rhino 5 ran perfectly for years with updates that fixed minor bugs specific to this early Mac version.

I’ve had very few problems with SketchUp or other apps on my Macs. Maybe I’ve just been lucky. But right now I’m delaying update to Big Sur because the loss of kernel extensions broke several apps. I think the real problem now is that many vendors support only a meager number of Mac developers in preference for the larger Windows market. Maybe the M1 and its successors will change that…

First time using Sketch up since the Big Sur upgrade. Worked on a model last night in laptop mode while watching the Super Bowl… plunged into the USB-C monitor and a day of frustration outline by what everyone else is seeing. I started to import the sketchup into layout because layout isn’t affected by this bug. On my last attempt I tried Apple Display just in case but still no “resolution”. So while reverting back from Apple Display the resolution on the USB-C monitor got wonkier. After adjusting the USB-C mon to the proper resolution… and well all is now fine in Sketchup World again with dimensions displaying correctly.

The problem is with Apple monitors, disconnect the monitor, open Sketchup and once the application is open, reconnect the monitor. It worked for me.
macOS Big Sur Versión 11.2.1

On a macbook air?

1 Like

Are you using an external monitor?

This is how it looked first.

And so I corrected it, connecting the external monitor, after opening the application.