Sketchup Make 2017 Mac OS Big Sur Dimension tool text up side down?

The problem is with Apple Monitors, unplug the monitor… I miss Steve Jobs…

If it is a “Big Sur” problem, why does it affect only SketchUp Make 2017 ? Or maybe SketchUp 2017 ?

If you read through this thread and others reporting the inverted text, you’ll see that it’s not just 2017 that is affected. You’ll also see that it appears to have something to do with the graphics and/or display being used.

So, there is two different issues :

  • it is M1 & Rosetta2 emulation. I read that other applications may have issues as Illustrator or Rhino 7 (that will be compatible soon). I tested Blender who work perfectly.

  • it is Big Sur. If Sketchup development respect Apple Guidelines, there is no other explanation than a bug from Big Sur. But I do not see other cases in other applications

Some 2017 users have reported they’ve fixed the problem. Kaplin, reported they’d solved the problem for themselves by disconnecting their Apple monitor. It’s no uncommon for Apple operating system updates to break things in 3rd party applications. There are plenty of examples of that over the years here and elsewhere. In any case, with SketchUp 2017 there wasn’t any problem with inverted dimensions before Big Sur. SketchUp 2017 hasn’t changed in about 3-1/2 years.

1 Like

It’s not surprising that the issue shows up only in SketchUp. SketchUp uses the OpenGL library more intensively and in different ways than just about any other software. In the past it frequently ran into issues with drivers that didn’t correctly implement a particular feature of OpenGL.

On the other hand, on Macs, in 18 years, we have hardly ever had driver problems, it was a problem that affected PCs.

I guess that’s changed in the last few years. The last several Mac OS updates have broken 3rd party applications. No matter what, SketchUp 2017 won’t be getting any updates at this stage. When operating systems change enough to make the old applications unusable, users will have to find an alternative. My old favorite 2D CAD program hasn’t worked on any operating system for a number of years. They say it’s progress.

Regarding Apple Silicon, this is really a technology that we are all going to move towards, with or without SketchUp. The M1 is twice as fast as the Intel machine that Apple (actually sold) gave me as a replacement for my machine from 4 years ago. Which makes a gain x4 compared to 4 years ago. There are rumors of new, even faster processors for this year. Apple not only widened the gap, but still has more power in store.

As an Apple share holder I sure hope that’s good news for them.

It would be nice though if Apple’s OS changes didn’t break applications, though. SketchUp 2019 had a late year update because a Mac OS update broke things. I believe SU2020 also had an update due to Mac OS changes. And it’s easy to think that maybe 2021 was released earlier than previous versions partly because of the changes with Big Sur.

It’s problematic, but I don’t see that much in other software. Now, I follow the development of Blender closely by regularly downloading the Alpha versions, which are not primarily developed for the Mac, and I am amazed by their stability. I use softwares which has not been updated for several years (admittedly, without OpenGL functions). Frankly, if there were so many issues with apps, I would have switched to PC.
I recently switched to Rhino7. Rhino 5 ran perfectly for years with updates that fixed minor bugs specific to this early Mac version.

I’ve had very few problems with SketchUp or other apps on my Macs. Maybe I’ve just been lucky. But right now I’m delaying update to Big Sur because the loss of kernel extensions broke several apps. I think the real problem now is that many vendors support only a meager number of Mac developers in preference for the larger Windows market. Maybe the M1 and its successors will change that…

First time using Sketch up since the Big Sur upgrade. Worked on a model last night in laptop mode while watching the Super Bowl… plunged into the USB-C monitor and a day of frustration outline by what everyone else is seeing. I started to import the sketchup into layout because layout isn’t affected by this bug. On my last attempt I tried Apple Display just in case but still no “resolution”. So while reverting back from Apple Display the resolution on the USB-C monitor got wonkier. After adjusting the USB-C mon to the proper resolution… and well all is now fine in Sketchup World again with dimensions displaying correctly.

The problem is with Apple monitors, disconnect the monitor, open Sketchup and once the application is open, reconnect the monitor. It worked for me.
macOS Big Sur Versión 11.2.1

On a macbook air?

1 Like

Are you using an external monitor?

This is how it looked first.

And so I corrected it, connecting the external monitor, after opening the application.

If I don’t have an external monitor? Upgrading to the current version (subscription) will fix the problem?

Old thread but worth a comment. One other person on this thread posted that using SideCar fixed the problem. I can confirm this workaround works for me as well. Mac Mini M1, running Big Sur, with an old iPad for Sidecar. Once I start Sidecar and re-open the file, the text shows normally.