Sketchup Make 2017 Mac OS Big Sur Dimension tool text up side down?

Thanks for checking. I still get the upside down text with the A12Z Mac mini, but no problems on my MacBook Pro.

On a Mac Mini with M1 :frowning:

Same problem after upgrading to Big Sur (MacBook Air 2017 & sketchup make 2017). So far I have found one way out - a model in desktop version Sketchup Make 2017 and dimension in online via Trimble

just noticed something…
dimensions are shown correctly on my laptop screen (m1 macbook air running Big Sur 11.1 Beta (20C5061b), but when i plug in my thunderbolt mac monitor the dimensiones get flipped on the monitor.

I then tried viewing on the monitor with my macbook open and it worked (the dimensions were shown correctly). So then i closed my monitor and continued to work on the same file. I dimensioned something again but the new dimension is flipped. So now on the same file there is one dimension shown correctly and one that is flipped. Pretty strange.

Screenshot attached

1 Like

Same here - text is upside down and back to front on external monitor, but displays okay if I drag the app into the MacBook built in screen, then drag it back again.

[SketchupMake - MacBook Pro 2017 Big Sur]

I have the same problem after I upgrade to Big Sur but when I connect iPad using sidecar, it fixed the dimension. The problem came back when I disconnected sidecar but the dimensioning done during iPad connected displayed correctly and stay that way.

Hello.
I have the same problem with dimensions and text. Sorry for stupid question, how you are doing dimensions in Trimble online :exploding_head:

Hello! Go to https://app.sketchup.com/app and find the Open button in the main menu. Download the desktop project file and work with it online. Once you can download the file to Mac (choose the correct sketchup version)

What is M1?

The Apple chips inside iPhone and iPad are called A1, A2, and so on (they are up to around A14 now). M1 is the first of the Apple Silicon “system on a chip” processors, as used in the new Macs that came out recently.

Colin; This what I have in my Mac, if it helps. My OS is Big Sur. I too am getting the upside down text in the Dimensions Tool. How can I fix it? Also, I am using SU2017DT.

Model Name: MacBook Air
Model Identifier: MacBookAir7,1
Processor Name: Dual-Core Intel Core i5
Processor Speed: 1.6 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Hyper-Threading Technology: Enabled
Memory: 4 GB
System Firmware Version: 425.0.0.0.0

I have two Macs that have Big Sur on them. On one the text looks ok in SketchUp 2017 dimensions. On the other one the text is upside down. I can’t tell what is different between the two systems.

Hopefully it is something in Big Sur that may get improved at some point. If it’s something in SketchUp 2017, that won’t ever be fixed, but I’ll keep looking for a work around.

The problem is with Apple Monitors, unplug the monitor… I miss Steve Jobs…

If it is a “Big Sur” problem, why does it affect only SketchUp Make 2017 ? Or maybe SketchUp 2017 ?

If you read through this thread and others reporting the inverted text, you’ll see that it’s not just 2017 that is affected. You’ll also see that it appears to have something to do with the graphics and/or display being used.

So, there is two different issues :

  • it is M1 & Rosetta2 emulation. I read that other applications may have issues as Illustrator or Rhino 7 (that will be compatible soon). I tested Blender who work perfectly.

  • it is Big Sur. If Sketchup development respect Apple Guidelines, there is no other explanation than a bug from Big Sur. But I do not see other cases in other applications

Some 2017 users have reported they’ve fixed the problem. Kaplin, reported they’d solved the problem for themselves by disconnecting their Apple monitor. It’s no uncommon for Apple operating system updates to break things in 3rd party applications. There are plenty of examples of that over the years here and elsewhere. In any case, with SketchUp 2017 there wasn’t any problem with inverted dimensions before Big Sur. SketchUp 2017 hasn’t changed in about 3-1/2 years.

1 Like

It’s not surprising that the issue shows up only in SketchUp. SketchUp uses the OpenGL library more intensively and in different ways than just about any other software. In the past it frequently ran into issues with drivers that didn’t correctly implement a particular feature of OpenGL.

On the other hand, on Macs, in 18 years, we have hardly ever had driver problems, it was a problem that affected PCs.

I guess that’s changed in the last few years. The last several Mac OS updates have broken 3rd party applications. No matter what, SketchUp 2017 won’t be getting any updates at this stage. When operating systems change enough to make the old applications unusable, users will have to find an alternative. My old favorite 2D CAD program hasn’t worked on any operating system for a number of years. They say it’s progress.