[SketchUp Make 2017] Bucket Tool doesn't have any colors by default?


#1

I’m new to the SketchUp,

as I proceeded with my creations, I wanted add color and textures.
After choosing the Bucket Tool I noticed that there is no colors or any textures preinstalled in the program.
I can create new and apply it to the project but every time I make a new design/project I have to make a new palette or colors and textures.
As I said I’m new to the program and although I searched forums about it I dont seem to find an answer.
My question is:

-Does SketchUp Make 2017 have a palette of colors and textures pre-installed by default?
(In that case either something went wrong in the installation, although i re-installed it 4-5 times)

-If no “default” palette comes with the installation, how can I have a palette of colors and textures loading by default everytime i start a new project? (if there is that possibility to do so)

For extra help I attach a video file in YouTube that shows what I mean that there are no colors palette in Material Tab

Thanks in advance for any replies of help.

(In Style > Edit > Style, I have Display shaded using textures and x-ray off)
I am using 64bit edition of SketchUp
Windows 7 Ultimate (fully updated)
GPU: Gigabyte NVidia GEFORCE GTX970 G1 4GB
Ram: 16Gm DDR3


#2

This has come up in the past. It’s been caused by an incorrect installation. When you install SketchUp on Windows, you need to right click on the installer and choose Run as administrator. Assuming you didn’t do that before, try it now and choose the Repair option.


#3

@DaveR, sadly I have tried it already but just to be sure I did it again but the problem persists.


#4

Hmmm…

Can you navigate to …ProgramData/SketchUp/SketchUp 2017/SketchUp/Materials and see if there’s anything in the directory?

It may be that you’ll need to uninstall SketchUp 2017 and reinstall it from scratch using Run as administrator from the right click menu.


#5

@DaveR, if you mean C:\Users"UserName"\AppData\Roaming\SketchUp\SketchUp 2017\SketchUp\Materials
no there wasn’t and isn’t anything in there. (even after the uninstall and reinstall as admin)


#6

This is odd. There was another report of this and reinstalling with Run as admin helped. I wonder if @DanRathbun might have a suggestion.


#7

You are talking two different locations.
They should be in the one Dave mentioned.
I’m guessing it’s a Permissions issue.


#8

Oops! I didn’t catch that. Thanks, Box. Yes. I was asking about ProgramData not User/App Data.


#9

at this location system wasnt allowing me to see “inside” the folder, I used TakeOwnership program to do so.
After so, yes there are folders and files in there, but when I launched SketchUp although the drop menu “sees” the folders doesnt show any of the files in the folders (as no colors or textures).

I had to run SketchUp as Admin in order to do so, after all. (but if I run the program as user the drop menu appears as the screenshot).

Now I can apply colors and textures after all, thanks for the help @DaveR and for the headsup for the folder location @Box .


#10

This makes me think you didn’t actually choose Run as administrator when you installed SketchUp. As as Box suggested, there’s a Permissions issue.


#11

I had tried it when I did the 2nd or 3rd (?) install to exclude that possibility and the last install I did it as admin as you advised me to to do so. (unless there is something messed up with my windows and doesnt allow me to do installs as admin(!) but still it should have warned me if it wasn’t unable to… I hope so at least).

I repeated the whole install as admin to be sure (after unistalling).
Same thing, had to use TakeOwnership at the :\ProgramData\SketchUp folder and run the SketchUp as Admin in order to have option in Materias Tab drop menu


#12

Well, as long as you got it to work it’s all good. It shouldn’t take all those gymnastics to make it work but maybe there is something with your Windows installation that made it more difficult.


#13

On Windows, if the SketchUp installer exe file is initially installed properly [using its context-menu > Run as administrator], then there should never be any need to change the way the resultant SketchUp.exe runs.
Indeed, although running that resultant exe [one-off] as the admin, or changing its Compatibility Properties to ‘Always Run as admin’ can simply mask issues - they really need fixing.
Running the SketchUp.exe itself as ‘the admin’ will also have hidden effects.
Windows-Explorer always runs at the lowest security setting, so when you elevate SketchUp.exe’s permissions, then you cannot then affect SketchUp from Windows-Explorer - so for example ‘drag-n-drop’ of images into the SketchUp window will no longer work…