SketchUp Mac SDK last 32-bit version?


#1

Hello,
Where can I download SketchUp Mac SDK last 32-bit version? The newest one that I see on the website is only 64 bit and I don’t see any kind of archive here of old versions. We need it, because our app is 32 bit and very big and complex, it relays on many other 32 bit frameworks (more than 15). It’s impossible to update them all. So, if you could give us a last 32 bit SDK, that would be great, even if it does not support the latest skp file format. We need the one that started using SU… functions (not the ancient one with ISkp… prefix).
Thank you.


#2

Hi,

I do have a copy of the SDK for SU 2013, though it is of course out of date in terms of features with the latest SDK, it will hopefully provide the features that you need. Attached is a minimal SDK that just includes the framework. I can’t make any updates to it or support it beyond advice on the forum.

(replacing in next post)

What product are you using the SDK for?

Hope this helps!
Paul


#3

I actually have a 2014 version for you here:

SDK_Mac_SU2014.zip (2.7 MB)

Thanks,
Paul


#4

Thank you so much, it worked!
We are making story boarding app and support tons of different file formats, including some 3D.
I just don’t understand why SketchUp framework could not be compiled as universal binary with several architectures inside, same as fbx sdk does. As I see many people in the forums ask about same thing.


#5

Great, glad to hear you’re in business!

Regarding the decision to be 64-bit only on Mac, the primary reason is that there are no OS/X 32-bit versions that are supported by SketchUp, and it’s a high maintenance and testing cost to continue to support both architectures.

Thanks,
Paul


#6

I can no longer get the latest SU because I work on an old 32 bit Mac Pro.I have probably the last version I can run which is SU Pro 14. The thing that really irks me is that I cannot open newer version files on 14 and I have to go back to my clients and ask them to save their files in a 14 version which is a real pain. Also, I recently tried to import an AutoCad file on my old SU 8 on another computer the other day and discovered there is no longer an option to do that, it has disappeared ???
If I am able to open Photoshop files that are years old without having to constantly upgrade Photoshop then why do you make users of SU have to jump through hoops to open old files ? You might make more profit in the short term but pretty soon now I will be forced to stop using SU altogether and you’ll no longer have my business. I shouldn’t have to be forced to buy a new Mac Pro for over $4000 just to be able to upgrade my SU version in order to open an old SU file or even import a popular type of CAD file. This is ridiculous and quite frankly I am completely over being on this exploitive merry-go-round. It is time you started treating your customers with more respect if you really want a lifetime commitment to your software.
I realize you can’t necessarily support old architecture but undermining old architecture to render your product useless is really inconsiderate, extremely annoying and eventually it will prove to be a bad business practice.If Photoshop can do it right why can’t SU ?