Sketchup LO auto save error

Hi everyone
I have problem of the Auto save.
Error code is 115.
Have anyone solved this problem before?

I am using Sketchup layout 2022. All of the sketchup data in the layout files are generated with Sketchup pro 2022.

I have been using this software for almost 4 years. But never had this problem.
Error pop up happen to the specific file.


Capture

MY PC’s Spec below

OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name PUTIN02-PC
System Manufacturer Dell Inc.
System Model Precision WorkStation T5500
System Type x64-based PC
System SKU
Processor Intel(R) Xeon(R) CPU X5675 @ 3.07GHz, 3060 Mhz, 6 Core(s), 12 Logical Processor(s)
Processor Intel(R) Xeon(R) CPU X5675 @ 3.07GHz, 3060 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date Dell Inc. A16, 28/05/2013
SMBIOS Version 2.5
Embedded Controller Version 255.255
BIOS Mode Legacy
BaseBoard Manufacturer Dell Inc.
BaseBoard Product 0CRH6C
BaseBoard Version A02
Platform Role SOHO Server
Secure Boot State Unsupported
PCR7 Configuration Binding Not Possible
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United Kingdom
Hardware Abstraction Layer Version = 10.0.19041.1566
User Name putin02-PC\putin02
Time Zone GMT Daylight Time
Installed Physical Memory (RAM) 48.0 GB
Total Physical Memory 48.0 GB
Available Physical Memory 32.7 GB
Total Virtual Memory 96.0 GB
Available Virtual Memory 74.1 GB
Page File Space 48.0 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Reasons for failed automatic device encryption: TPM is not usable, PCR7 binding is not supported, Hardware Security Test Interface failed and device is not Modern Standby, Un-allowed DMA capable bus/device(s) detected, TPM is not usable
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware No
Hyper-V - Data Execution Protection Yes

An earlier thread got this response from the SU team:

“There’s no public list of error codes - the codes are only used for problems that are supposed to be rare.”

So you might need to refer it to Support.

1 Like

Thank you Simon
Ok I will do it.

Hi @Masunami,

Error code 115 means that there is a connection point that was made improperly somehow, possibly during a copy/paste operation or duplication of pages that contained connection points. Connection points are what LayOut uses to connect labels to SketchUp model viewports, for example.

This was likely not something you did wrong, but rather a bug in LayOut that produced this bad connection point.

It may be possible to recover this file by manually editing out the bad connection point (the usual method is to rename .layout to .zip, extract the zipped contents, modify the appropriate .xml file(s), then rezip the contents and rename back to .layout).

We are looking at a way to automatically fix this 115 error in the future such that this error should never be seen again.

Adam

1 Like

It would be handy to know if this is a bug confined to SU2022.

Ok, I just renamed it to .zip and extracted the zipped contents as you advised.
I do not know which .xml files are not appropriate and how to fix them.

Could you advise me about this?

I have extracted .xml files such as
document.xml
documentProperties.xml
references.xml
styleManager.xml

I have attached all of .xml files below in the zipfolder.

styleManager.zip (21.4 KB)

Thank you very much again.

Sorry I misunderstood about the .xml files.
There are a lots of .xml files in extracted the zipped contents.

Anyway I have no idea about the bad connection points and how to recover this file by manually editing out.

I am trying to copy the all text and hatching data from original layout file to new layout file, and linking it to new SketchUp files copied from original SketchUp file. As I assumed the bad connection is happening between the original layout file and original sketchup file.

Ok I tried this but it did not work.

So perhaps there is a problem in text or hatches or model itself.