Sketchup Layout 2023 extremely slow


this is my first time using a forum.

Last week I made the update to Sketchup 2023, sketchup works fine but it’s not possible to use Layout. If I try to make dimensions to the model in rendered mode ( which works easy in LO 2022) it’s extremely slow. When I tried to uninstall SU23 and opened SU22 it says, I am not authorized to use SU…

My workflow now is to model in SU 23, send it to LO2023 and downgrade it to LO2022 → luckily I am able to use LO 2022, but it’s not comfortable to switch between these versions and I am not sure if it is a stable workflow…

Do you have any Ideas why LO23 is so extremely slow? And is there an easy way to go back to SU22 without saying I am not authorized?

Can you share a troublesome LO file?

Hi Dave,

thanks four your quick reply. This is a Testfile I created:

Test 2.layout (2.6 MB)

Is it slower than this? I recorded this in LO2023 on Windows.

yes, its like it is hard to snap the points

I wonder if this is related to the graphics on Mac with M1. Perhaps @adam has some input.

1 Like

@SusanneBerlin @DaveR, We have found an issue that is causing this very negative impact for mac users and we are working on getting a fix released as quickly as we can. Windows users are unaffected, hence the difference in what each of you is experiencing.



On the question of being authorized, each version of SketchUp you sign in on counts against the number you can be signed in on. Had you signed out from 2023 before using 2022, I think it would have worked without any complaints.

Also, if for some reason you had been signed in with 2022 with a different email, that would think you weren’t authorized. You could open both, sign out from both, sign in with the right email in 2022.

@Adam good to know, thank you!

@Colin perfect! You saved me. I logged out in 2023 and I am now back on 2022.

thank you all for you quick reply!

Hope you are able to fix it quickly as foolish enough I trashed the old version.

Hi all, we just released a patch for 2023 that includes a fix for this issue.
You can use the in product “Check for Updates” to get the latest.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.