Sketchup is very slow

My sketchup works veeery slow. and vray… i even can not work with it. it’s driving me crazy help please.

I updated my GraficCard and did that open GL setting but nothing helps.

uh haven’t heard about Enscape3D :thinking: is worth trying

Big (interior) architectural offices are already shifting… It’s a no brainer to go away from traditional renderers. Enscape3D is a new breeze into the render landscape that takes the place like storm. No more waiting minutes for renders. 1920 pixel screensize in 4 seconds… ;))

1 Like

I see you have a decent card Nvidia Geforce RTX 2070. Enscape3D is, as we speak, working onto the support for real-time tracing…


Your profile indicates Mac…

How do you manage to run Enscape? Or do you use a different machine?

Did you see which card SketchUp uses in Graphic Card details?

I haven’t received my PC jet. I’ve will have both setups… Even Apple told me to go away from Mac #bummer #wehavetomoveon

1 Like

no i didn’t. where i can check that?

i’m eager to move on with new technology and softwares. Enscape3D looks very interesting.

Enscape do run on a Mac. You need OpenGL 4.3 if I’m. not mistaken. It’s not officially supported…

Give it an honest try Sadeki. You can rent the software by the month. No-brainers does exist :wink:

1 Like

Check within SketchUp: Window->Preferences->OpenGL->Graphic Card Details…


So SketchUp uses the right one!
How big is your model? Do you have this behavior with all models?

hmmm :thinking: the project is really not big at all, but weird that only this project works that slow. maybe it’s a component I downloaded from Warehouse causes this problem. is that possible?

Yes, that is very likely…

1 Like

have a look at
This GREAT plugin (PAID) helps you to downsize an object in seconds and preserving or swapping the textures

Try the Goldilocks plugin. It may help figure out what is large in your file. Don’t forget to purge in the Model Info window as you fix the model.