Sketchup for Web not loading most recent version of file

I am using Sketchup for Web, and saving my projects in the Sketchup folder in Trimble Connect. There are two different computers that I am often using to work on the same projects. Until recently, this worked fine. I could work on a project on one computer, save it, and later open it up on a different computer.

However, recently this has stopped working. Now, whenever I open up a project from Trimble Connect, it always opens up the version of that project that was last saved on that particular device. So, if the last time I worked on that project was from a different device, it will open up an old version of the project, instead of the up-to-date version.

This happens regardless of whether or not I open the project from “Recent Projects”, or navigate to “Trimble Connect” and open it from there.

I can open the most recent version if I click on the three dots, select “History”, and then select the most recent version of the file. However, it opens it up as an untitled project, which I then have to use “Save As” to overwrite the original file.

I have tried this with several different projects, and it always exhibits the same behaviour.

Any thoughts on how to correct this? Or is this just a bug that was introduced to SketchUp for Web with some recent update?

1 Like

I can see it, too. The web-saved versions also don’t load in the 3D Viewer of Trimble Connect.

I did more testing and I was able to reproduce it - We will investigate and release a fix but in the meantime here is a work-around:

  • Before you open the project from “Recent Files”, click on “Trimble Connect” and then click back on “HOME” and open the project. The model should be up-to-date.

I did a bit more testing, and the same issue happens if you switch between browsers on the same computer.

Thanks for the work-around, that is more reasonable than overwriting the file each time I change computers.

I had to change the workflow slightly to make it work, I’ll put it here in case anyone else is having the same issue:

  • Instead of selecting “Open” in the dropdown menu, select “Home”
  • Don’t select the file under “Recent Files”, instead select “Trimble Connect”
  • Select the file in that window.

After more testing, neither work-around works consistently. The only solution that I have found that consistently works is to load the most recent version from the file history, and then overwrite the original file. The workflow for this is as follows:

  • Select the three dots under the project name
  • Select “History”
  • Choose the most recent version of the file from the revision history and select “Show in editor”
  • An untitled project will open, which is the most recent version of the project
  • Select “Save”, and choose the same name as the original project
  • The untitled version of the project will overwrite the original project
  • You will now have the most up-to-date version of the project.

@stu.crawford The issue is resolved as of today, please let us know if you are still having issues.

Thank you,


This topic was automatically closed after 91 days. New replies are no longer allowed.