SketchUp for Schools Login Issues - Official Thread

I have uninstalled and reinstalled as the domain admin several times…still not working. I have a web meeting with Tori from SketchUP at 11:30am today. Hopefully, we can get this resolved.

Same issue as others on this thread: Uninstalled and reinstalled multiple times but can’t login from our domain. Please whitelist: fms.k12.nm.us

Good morning, our students seem to be having login trouble. Please whitelist @myips.org and @students.myips.org

They are experience new login errors, need for admin, are you in the right place and the loop back to install error

Please confirm when you’ve completed this.

Alex White
Instructor Architecture
Arsenal Tech High School
whitea@myips.org

2 posts were merged into an existing topic: Domain Registration Requests

Hi Steve,
I am experiencing the log in issue as well. I tried to Sign in with google and I got the error message" Are you in the write place". Therefore, I tried to log in with Microsoft and I got a message" Need Admin approval"
Could you please whitelist our domains?
Faculty Domain: @camdencc.edu
Students Domain: @students.camdencc.edu

I have registered both of your user domains so you should be good to go. Please try logging in again and let me know if your login issues persist.

Unfortunately, I still get the " need admin approval" error message!?

Steve,
Our district is wanting a privacy disclosure signed by Sketchup. Is there a contact on your side who can help with this? I have the agreement, just need it signed from your end. Any help getting this done would be appreciated.
Gary Stalions
gstalions@sjusd.org