Sketchup For Schools Components 3D Warehouse Error

I am a teacher attempting to use Sketchup For Schools. I have attempted to download/import a component from the 3D warehouse and I receive an error message. This is a new error. Is this a problem anyone else is having?

What’s the component and what’s the error message exactly?

Weird, it started working for some reason.

That’s good. It would still be useful to know what component you were after and what the error message was.

It is still occurring for my counterpart…saying “I’m still getting the error. I’m using Chrome. It happens even if I start a new file or if I open an old one and try to import into it.”

What is the component you are trying to download?

Any and all components. #suforschoolsoz will not even work within the tutorial.

1 Like

Share your SketchUp model file so we can see what you’ve got going on.

I hunted through the 3D Warehouse for an author called “Table” as shown in your screen shot. Except for the stone wall, none of those other components appear to be available.

I am having the same issue. It doesn’t seem to matter what I try to insert from 3D Warehouse, I get the “Oh, no. An error occured while downloading this component.” message.

Design room.skp (117.3 KB)
Here is the file I’m working with…

What are you trying to add specifically? What browser are you using? Are you doing this using a school computer and network?

I just added a lab table from the 3DWH without problem so I doubt it’s the model.

A little off topic but it would be a good idea to use components as you go through the modeling process. As it is, all your model is loose geometry and there are a lot of exposed back faces.

Thanks for the tips. This is my refresher for myself, modeling my new classroom and remembering all the details I’m going to have to teach my students. :slight_smile: After this quick sketch, I realized exactly what you just pointed out, and am constructing the shelving as a component. I’ll add the radiators after as well. Also, gave thickness to the walls for 8" block.

There is a lot new at our school this year, and I’m wondering if our IT department added some new security features that are blocking the downloads of 3D warehouse items. Does that sound possible? No trouble with it last year, but I’m running a school laptop from home through a school VPN, so the network behaves like I’m at school. If multiple teachers are having similar issues, I wonder what the connection is?

:+1: :+1:

It does indeed sound possible. Or it could be the VPN. It would be worth checking with the IT folks to see. Certainly if you want your students to access the Warehouse this year, it’ll be good to get it sorted out early.

We’re having the same issue with importing anything from the 3D warehouse even into empty projects - same error as tsimpson - we are a New South Wales Dept of Education school - tried different browsers but to no avail - we’re starting a project this week - this wasn’t a problem earlier in the year.

Same issues here faced. We’re using MACs in school. Tried Safari and Chrome browsers. Nothing could be imported from 3D warehouse. I believe something is broken of recent weeks when my students aren’t able to import anything from 3D warehouse.

Certainly hope this issue gets looked at and will find a resolution as I’m starting my Sketchup assignment with my kids next week! fingers crossed

Not to add without a solution but this has started happening to me this week. I can no longer download from 3D Warehouse. I’m on a 2017 macbook running Monterey 12.5 and was not having any issues until about a week ago. Anyone find a solution or resolve to this?

Not sure if this will help everyone but we found a workaround for our school - if the students sign into 3d warehouse separately to the sketchup for schools and sign in with the same google credentials (ie open 3d warehouse in a new tab) then it will then work