Oh no! An error occurred while downloading this component. Sketchup for Schools

Greetings,
I have searched and found that this issue has been around before. No solution though. We are using Sketchup for Schools and no components can be downloaded from the 3D Warehouse.

We have tried school accounts from different school districts across work and home WiFi, as well as different browsers and machines. All show a red error indicating an issue with all components.

"Oh no! An error occurred while downloading this component. "

Please help. We are trying to get this unit started and would like to use components. Yes, we tried going directly to https://3dwarehouse.sketchup.com/ and that does not work.

Same here. We are running version 1.3 and seem to have the same issues. Hope it is temporary.

Same issue here.
Tried it in Edge and Chrome.
That said, it seems to work in the Sketchup For Schools app.
Edit: I also found an older thread about signing in to 3d warehouse, then going back to Sketchup and that works, but we use single-sign-on for Sketchup For Schools and 3D warehouse doesn’t support that.

We have the same issue where students can only use Office 365 to log in and not Gmail. There has to be someone from Sketchup reading these that can tell us what is going on. We started the unit and need the components to work.

@selfdestruktor I didn’t know that Sketchup for Schools has an app.

I had reported the same problem for Windows users downloading models in the desktop version of SketchUp. Mac users can download ok. Seems to be the same issue with SketchUp for Schools, I can download any model on Mac, but the same model fails on Windows.

I will try to get someone to look into this right away.

Thank you all for bringing this to our attention. As Colin mentioned earlier, the bug has been reported it and our team is working to address the issue as soon as possible. We’ll provide an update when we have more information.

Thank you! I believe the issue has been resolved.

Thank you, we are having the issue too!

Thank you, we are still having the issue as well.

We think we see what has changed that caused the new problem. Hopefully the team for that feature will be able to fix the problem.

So it seems like it works only if the browser you are using is already signed into 3Dwarehouse.sketchup.com. This is not a great solution as we then must sign into every student PC with a new Gmail we created as the students don’t have one.

Can I ask, are you signing in with Microsoft to use SketchUp for Schools? I can see how that would not involve a Google sign in.

Students are using Microsoft to sign in to their SketchUp account to do the work, however for some reason 3D Warehouse does not allow for Microsoft credentials. It only has Google and apple. Therefore, we created the generic Google account that we’re signing in for all the students. We are talking about over 300 of them so this is very tedious.

Thanks it was fixed when I checked a little while ago

Getting in on the conversation…
Our school, in Australia, uses Microsoft single-sign-on and it’s still not working unless they sign in to 3D Warehouse with a separate account.
It’d be GREAT if 3D Warehouse had the same authentication system.

Just signed out of 3Dwarehouse with Google and Sketchup still does not work with downloading components.

There was a change in the 3D Warehouse that really doesn’t relate at all to SketchUp for Schools, but it had a side effect, where some users would seem like they were not authorized to download components.

That unrelated change has been reverted for now, until it can be put back in place without the unintended side effect.

Downloading components should be working again.

It’s working for us!
Awesome!