SketchUp for Schools - Are you in the right place error

No-one at our school can login to Sketchup for schools - we get the error “Are you in the right place?” and clicking sign in with Google goes through the login process and returns to the same page. Your forum indicates that you may need to register our school domain riverview.nsw.edu.au (with several sub domains)

I tried to use this forum last week


but I was get an unhelpful error saying “new registrations are not allowed (Maximum reached) contact a staff member” I reported this to ProSupport prosupport@sketchup.com but they never got back to me. I have now tethered to my phone and can now post on the forum.

We have used Sketchup for Schools before, its installed and access granted in Google admin but obviously something has changed.

Please advise

1 Like

Happy to read about this error (not about the error itself! :wink:). We are having exactly the same problem at our school (school domain albalonga.es). But: in most of our computers/Google Workspace Users, it does work properly; it is just in a few per class where it doesn’t work. So, apart from the trouble itself, it is unconsistent.
We tried options:
Same computer, different users: in some cases it works for nobody, in some other it does;
Same troubled user, different computers: in some cases it all gets solved, in some other not;
So, it’s really difficult to get a clue.
I don’t know if my comment provides help, but I think at least shows that the problem is not yours alone :slightly_smiling_face:

OMG, no wonder Sketchup did not reply. It looks like there are multiple issues. Having read the other posts on the topic I thought it was just a case of Sketchup adding the domain.

I might go back and post on those old forum posts and see if I get any response.