SketchUp export to indesign


#1

I have a series of 2D drawings I need to export as an .indd file for further work within inDesign. Is there an extension or a technique I can use to work this out?


#2

SketchUp can not export as .indd but many other formats which inDesign can import.

File>Export>2D graphics

choose the format (PNG,JPEG,TIFF etc)


#3

if you wanna edit in InDesign don’t export as raster data but as vector data in the DWG or PDF format… using them textures will not make it through.


#4

It depends on your page size in INDD, especially if you are planning on printing the material from INDD.

If your image is a simple line drawing with flat colours make sure to export it as Vector as @sketch3d_de said .

However if you are unable to do this then export as a PNG as high as possible with 300pi. This does not equate exactly to DPI but it’s close enough. INDD was my main tool when I was freelance for illustration, these images are over 10k*15k pixels for print.

If you need to export as raster (and if exporting at a large canvas size as suggested) then you can turn AA off in the export settings to give you cleaner edges (in some cases).


#5

My preferred method has always been SU to EPS to Illustrator to ID. Seems a but cumbersome but like liamk887 said, when in ID, it’s best to use Vector when possible. One note is that if you have a big model or area you’re importing from SU to AI to ID, it may come in as flattened .eps…which basically removes a lot of the benefits of working with vector graphics. So if I have a big model, either export in pieces in SU or grab smaller groups one at a time in AI and paste directly into page in ID. That way the vector is preserved and all stroke/fill functionality can be directly edited in ID, eliminating need to go back to either SU or AI to make small changes.
See below:

  1. SU to EPS
  2. EPS to AI
  3. Try to paste whole thing at once into ID and it merges as flat eps = no bueno.
  4. Paste smaller sections of model one at a time and vector preserved…let the fun begin!

#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.