SketchUp defaulting to my Intel Graphics card instead of my AMD card

Hi I am hoping for some help please?
When I launch Sketch UP 2019 on my PC I get a warning that Sketch up defaulting to my Intel Graphics card instead of my AMD FirePro W4190M.
I would like to change this so Sketch up defaults to my AMD card.
I have followed all sorts of online instructions and landed myself here (please see screen grab), but I am not tech savvy at all and don’t know if I am in the right place or what to do from here. I would love some help.
Many thanks.
image

first of all, as always, ensure that the latest driver version of your AMD Firepro is installed.

dunno which driver version installed?: “Win+R > dxdiag > Display”

There are also Windows OS level settings.
To set or change them, exit all running instances of SketchUp.

  1. Right-click desktop and choose “Display Settings” (from context menu.)

  2. Scroll to the bottom of the Display panel and choose “Graphics Settings

  3. Verify that “Classic app” is set for the “Choose an app to set preference” type drop down list,
    and then click the Browse button.

  4. Browse to "C:/Program Files/SketchUp/SketchUp 2019/" and choose the "SketchUp.exe" file and click the Add button.
    (A “SketchUp Application” tile is added to the “Graphics Settings” dialog. Usually with the “system default” GPU assigned.)

  5. Click the Options button within this new application tile.
    A “Graphics Specifications” dialog pops up where you can choose “High Performance”.

  6. Your system should have your AMD FirePro as the “High Performance GPU”.
    Choose the High Performance setting and then the Save button.

  7. Start SketchUp 2019, and open the Preferences dialog from the Window menu.
    Choose the OpenGL panel and click the Graphics Card Details button.
    Verify that SketchUp is using your AMD GPU (the vendor should say AMD instead if Intel.)


The “Graphics Specifications” dialog looks like this on my machine before making changes.
(I use dark mode BTW.) …

image


Good Luck.

1 Like

Thank you Dan!

1 Like