Sketchup crashes when importing dwg after installing the new high sierra mac-update


#1

Anyone know how to fix this? It’s very urgent.

I’m desperate. Have tried installing everything again. Still doesn’t work.


#2

are you using the High Sierra version of SU?

john


#3

Note: @john_drivenupthewall is referring to 17.3.116. You can check this via the SketchUp->About SketchUp menu item.


#4

Is there an own sketchup high sierra version?


#5

13

this is my version. is that the problem?


#6

What is an “own SketchUp version”?


#7

yes, using the version that was updated to solve ‘some’ of the HS issues will help get it working…

it’s the mac one on the downloads site…

john


#8

Yes, 17.2.2554 has multiple known issues on High Sierra. 17.3.116 was released specifically to address most of them (there are still occasional glitches being reported). 17.3.116 is what you will get if you download a fresh installer from the Trimble site.


#9

Thank you (and thanks everyone else also) now the sketchup store seem to be unavailable for maintenance. I guess it’s just one of those days, right.

Thank you for answering! :slight_smile:


#10

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.