Sketchup Animation .avi Export

Ahoy there,

We have a presentation coming up and the client has requested a fly-around and walkthrough of our proposal. This is all fine and dandy, however whenever I try to export an ‘avi’, it refuses to create the file. (despite rendering it completely). It’s pretty important that we use avi, as the other formats don’t produce satisfactory results.

The alternative would have been to export image by image, but the facilities to do so don’t allow anti alliasing. I know this has been posted about previously, but there wasn’t any resolution.

What is the solution?


Hi, I don’t remember seeing this topic before—if you have a link I’d like to see it, so I can brush up on the conversations of the past.

You don’t mention it, and I don’t mean to accuse you of making any rookie mistakes…but are you absolutely sure where this file is being saved to? … and you’ve gone through all of the standard search methods for tracking down a misplaced file?

Alternatively, are you also ensuring that the .avi extension is being added into the file name (within the Save As text box)?… this typically would be filled in automatically, but if you don’t see it, then I’d certainly manually enter it in after the file name—just for the purposes of troubleshooting.

Have you also gone into the ‘Options…’ settings and attempted to change any of the default settings which are present, and trying the export again with slightly different conditions.

And as always; What version of SketchUp do you have, and what OS is it running on… and for that matter what about your other computer specs…RAM, Video Card, and CPU…???

If you want to, for practical purposes, and because this is a presentation which probably has a timeframe of some sort. I say post up your model and let someone else create the export to .avi for you right away.

I’ll volunteer myself, of course, but I’m sure others will be able to do that as well. Troubleshooting this issue doesn’t have to come at the expense of keeping your client waiting if you’re up against a deadline on this… which I’m just saying as a quick solution.

It’s also immensely useful to work with the original file when trying to troubleshoot issues. Group testing could confirm a problem, if this is going to be a bug of sorts between a certain version of SU, and an OS.

The conversation here was suuuuper brief:

There was another on Sketchucation

Yeah, it’s cool, I ask similar questions of others. File location double and triple checked. It seems to work with a smaller file size (ie a shorter animation, or if I cancel this one after a couple hundred frames). The file extension was also populated by default.

At work I’m running Sketchup 2015, on Windows 7 64bit, i7 2.8(ish??) 8gb DDR3, Quadro FX 580 (512mb ram).

I also tried at home with my PC, to no avail. It has much beefier specs: Sketchup 2015 on Windows 10 (64 bit)
CPU: Xeon e3 1231 @ 3.4ghz
RAM: 16gb DDR3
GPU: GTX 970 4GB.

If this was a student project I’d be all for sharing, but unfortunately, it’s a medium scale commercial development. This deadline isn’t immediate, and this was more of a test run to make sure it works prior to investing my time in a full walkthrough.

I also tried with a simpler model (just made a similar length animation). It seems that everytime the ‘estimated size’ reaches approx 4000mb (I’m guessing 4096) it starts back at zero. Is there an artificial file size limit? (I’m also on NTFS so it’s not a formatting issue)

The 4GB sounds like the Windows limit for 32-bit applications. I thought SketchUp was compiled with the Large Address Aware switch since 2013 or so.

Are you running the 64-bit or 32-bit SketchUp edition ?

Wikipedia article: x86-64 said:

Prior to Windows 8.1/Windows Server 2012 R2, Windows for x64 offered:

  • 8 TB of virtual address space per process, accessible from both user mode and kernel mode, referred to as the user mode address space. An x64 program can use all of this, subject to backing store limits on the system, and provided it is linked with the “large address aware” option. This is a 4096-fold increase over the default 2 GB user-mode virtual address space offered by 32-bit Windows.

The following additional characteristics apply to all x64 versions of Windows:

  • Ability to run existing 32-bit applications (.exe programs) and dynamic link libraries (.dlls) using WoW64. Furthermore, a 32-bit program, if it was linked with the “large address aware” option, can use up to 4 GB of virtual address space in 64-bit Windows, instead of the default 2 GB (optional 3 GB with /3GB boot option and “large address aware” link option) offered by 32-bit Windows. Unlike the use of the /3GB boot option on x86, this does not reduce the kernel mode virtual address space available to the operating system. 32-bit applications can therefore benefit from running on x64 Windows even if they are not recompiled for x86-64.

  • Both 32- and 64-bit applications, if not linked with “large address aware,” are limited to 2 GB of virtual address space.

Yep, sketchup was definitely made 64 bit a couple years ago and that’s the
version I have.

Only the last version SketchUp 2015 has a 64-bit edition, and it was released less than a year ago (last November.)

You can check (to be sure) by opening the Ruby Console inside SketchUp, and typing the command:


Yeah, my apologies, time flies - but apparently not quite that fast.

My sketchup is definitely 64bit though, both that command and the ‘about’ section indicate as such.

OK, well what is the size of your system swap file ? (Those articles indicate the swap/paging file size can also limit application memory.)

Control Panel > System (applet) > Advanced (tab) > Performance (group) > Settings… (button) > Advanced (tab on Performance Options dialog) > Virtual memory (group)

Increase via the Change… (button)

Mine is set to auto-manage (on the Virtual Memory dialog) and is equal to my system memory which is a mere 3GB, (even though the system recommends it be 4.5GB. I wonder why that is?)

It’s on system managed (automatic) as well, currently at about 2.4gb with a
recommended at 2.9gb

Really that small … How much system RAM do you have ?
EDIT: I looked back, and saw you said 8GB at work, and 16GB at home.

Well then if you have a lot of space on your harddrive, manually set the pagingfile size to 8GB, and see how that works ?

(I personally would de-fragment the drive, first though.)

Gave that a shot, set it to 8gb to no avail. Exact same thing occurs. I had a good feeling about that one too :frowning:

I did a search through the Release Notes, but could not find anything specific to a output file size limit.

You might be forced to stitch avi files together with MovieMaker or some similar application.
Or just have SketchUp ouput the single frame pngs, and have the external video application make the avi. (That is how it was done prior to SketchUp 2013.)

Yeah, I think it may pertain to whatever the encoder it uses is. I think I’ll go with the stitching of stills. It means I can still have one animation (and subsequently one file). Thanks for your time any way, I appreciate your effort.

No problem. Another thing about external stitchin’ is you can add voice over, music, and captions. And other effects, fade in, etc.

Testing a link insert browser plugin,
by pasting a link into the SketchUp User’s Guide:
Exporting an Animation

SAME problem HERE! :frowning: does the whole process, and then, no video file to be found after. think its, when the video is gonna be over certain size 4 gigs (?), its fails. guess u could make multiple copies of sketcup file, make multiple vids and combine later

Yes there is a memory limitation on Windows for each application process, and also by how much RAM your computer has.

You can also try using a compressed format like mp4, instead of avi.