Sketchup <> Affinity Designer DWG export and import

Latest release of the Affinity Suite (Designer, Photo, Publisher) has now just added DWG/DXF export to its earlier import capabilities.

So as a quick test of no particular purpose other that to see how stable it was I took a recent SU model of bricks and imported it into Affinity Designer (AD).

The process was simple and fast and AD had no trouble with the number of individual edges

So I played around with the AD edge manipulation (Stroke and Brush) tools and they worked fine.

So tried so more extreme manipulations (Extend Curves) in AD and that ran smoothly

And the exported that back into SU as a DWG successfully as vector linework

So all those committed to ADOBE subscription licenses because you needed Illustrators DWG export and import capabilities you really have a serious alternative compliment to SU for your adventurous graphical needs and it NOT subscription software !


All that’s missing is a dimensioning tool, and Affinity Designer can be an alternative to Layout.
There are some features in Affinity Designer that have been requested in Layout for years.
And WITHOUT subscription!

1 Like

Do you know if it’s possible to make the original vector in Designer and import it to SketchUp as a shape? I’ve tried both DXF and DWG and it doesn’t work. It would be great if it worked, because the vector tools in Designer are so much more comprehensive than the drawing tools in SU.

I’ve been using Designer to create icons and cursors for my extensions, but never tried using it to create an importable shape for SketchUp. I’ll give it a try later when I get som free time.

1 Like

It works perfectly for me…

First off, I’m on an all-iPad workflow. But here are some shots, perhaps you can spot something I’m doing wrong. I tried two ways of importing: making a file and using the import button, or just opening the DXF directly from the Home Screen using the open from . . . b


I’ll try later with ipad…

hmmm can you share your dxf / dwg here ? so we can try on pro ?

if it opens fine on pro then su ipad has a problem, but if it doen’t open on pro either, then affinity’s export is at fault, if you follow my thought :slight_smile:

I tried with iPad and it worked too

Have you tried to use zoom extend? Maybe your drawing is there but units are different…

I got time and tried on my Mac. It worked for me too. So, there is something specific you are doing on the iPad that is the issue. If, as @ateliernab requested, you can share the dwg or dxf here, we can examine it to see what might be amiss.

Edit: On the iPad, at first I saw nothing but when, as @rtches suggested, I did zoom extents, there it was. There may be a need to pay close attention to the units of the Designer document vs the scale in SketchUp.

Gear2.dxf (72.0 KB)
Geardwg.dwg (13.7 KB)
Here’s the DXF and the DWg I tried.

Just saw all these comments on my initial post… I am using SU 2021 and Affinity Designer 2.4 (latest build) both on a W10 PC.

I just did a quick test creating a native AD drawing and imported into SU as a DWG.

make sure you actually have a stroke width on your AD shapes… AD shapes came in fine without any need to “convert to curves” and expect if you distort them with the warp tool you will need to do that!
Stroke widths will be ignored and replaced with edges

Also remember SU will segment curved edge imports so don’t expect accuracy, not sure how you could adjust arc segment resolution on or post import, maybe a plugin exists?

Dimensions and Area tools are in AD but only transient .

1 Like

I tried to import your file in SketchUp for ipad and I had an empty model. I tried on SketchUp Pro and I received this error

Make sure you have a stroke in your shapes as @gsharp says

1 Like

hmmm, there are a lot of parameter setting when creating the file in AD,

here is my settings those t, maybe one of them affects the success

Yea, gotta have a stroke, that did it. But for some reason I can’t erase the hole in the middle. I imagine a little noodling will fix it, thanks for the help everyone!