SketchUp 2019 + plugins from external sources problem

For a few years now I have used a junction (mklink /j) to refer the default SketchUp folder
C:\Users\XYZ\AppData\Roaming\SketchUp\SketchUp 2019\SketchUp\Plugins
to another drive that gets backupped daily. Always working fine.

The problem in the new V2019 is;

  • plugins I install from the extension warehouse install and work nicely but are not present anymore when I restart SketchUp.
  • After restarting SketchUp they are visible and enabled in the extension manager.
  • They are not visible anywhere in any toolbar (gaps). They also not visible in the list from the menu option View-Toolbars
  • If I re-install just one plugin from the extension warehouse again, that plugin and all other plugins that were previously installed are visible all at once as well again and working nicely.
  • At that point, many plugins that were installed using the SketchUcation plugin manager are visible again as well.

Installed as admin. Re-installed as admin. Tried with just one plugin (selection toys).

My own plugins show up nicely though (tested without them as well).

Any suggestions?

Edit: re-installed everything. Dropped the junction. Installed Fredo’s ‘additional folders plugin’. Now it works again.

1 Like

Has this setup ever worked for you with SketchUp? It sounds like the actual location of the Plugins folder (target) becomes only resolved when an event triggers it (like installation of an extension, but strangely not read access for initial loading of extensions).

I have been using (unix) symbolic links for this purpose for years. The idea of using junctions is new to me. It seems junctions and symbolic links have subtle differences (e.g. on Windows symbolic links require root/admin permissions).

The following site suggests (in my understanding) that a junction can only target local paths, or at least it is resolved differently: https://superuser.com/questions/343074/directory-junction-vs-directory-symbolic-link
Have you tried symbolic links?

The advantage of file system transparent solutions (symbolic links, junctions) is that they work with all applications because they don’t see it (except using realpath). Some SketchUp extensions expect file locations relative to the Plugins folder (and not relative to the extension’s loader file), this can cause problems when side-loading from an external path (load "X:/…/script.rb") or adding paths to the Ruby load path.

Yes the junction (using mklink /j etc) worked for me for several years without any problem. I will have a look at making a symbolic link.

Edit: just tested the symbolic link (mklink /d) and its the same problem. So for now using Fredo’s solution

I have the same issue with my building creator extension. The extension shows up in the extension manager, but my tool bar/ menu items are missing. I can manually load the extension from the ruby console and it works just fine. What is Fredo’s solution mentioned above?

a simple loader script in the SU ‘user’ plugins folder, that calls require_all on the path to your ‘alternate’ plugins folder…

if it’s ever been loaded it will show until removed, but if you test for a module method, they will only be defined if the files are loaded in the current session…

john

https://sketchucation.com/forums/viewtopic.php?f=323&t=39073

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.