SketchUp 2018 Crashes when I use the offset tool

bug

#1

When I use the offset tool, the program crashes but does not give me any notice about an error or option to send a report. The object area I am working with is about 58 acres. When I make a smaller object and use the offset tool, it works fine. What could be going wrong?


#2

Could be that it’s just too big. Which version of SketchUp are you using?


#3

I just bought a student license of SketchUp 2018


#4

Maybe you could fix your profile. It indicates you’re using the web-based version.

Two things to check regarding your problem.

  1. Did you install SketchUp correctly? That is, did you right click on the installer and choose Run as administrator? This needs to be done under your normal log in. If you didn’t do that or you aren’t sure, do it now. When the option presents itself, choose Repair.

  2. A common reason for crashes without a Bug Splat or other warning message is related to graphics drivers. Although Intel graphics are not recommended, people do manage to make them work. You do have to keep up on the drivers for it, though. Try updating the drivers and see what happens.

Be aware that Microsoft pushes updates automatically and they often update Intel graphics drivers. Unfortunately it seems they push inferior driver versions that create problems. You have to stay on top of that and watch those automatic updates.


#5

Ok, I managed to make it work by chunking up my site area and doing the offset in small pieces at a time. This is tedious though and I’ll try your suggestions to see if that works.


#6

I’m not sure if I chose Run as Administrator. How would I do that?


#7

From my previous post:


#8

So you’re saying I need to reinstall it?


#9

No. I’m saying you need to use Run as administrator and then repair the installation.


#10

I have just encountered a similar situation, several times. I am trying to offset 400m, Fairly simple geometry. Model is probably quite a few Mb as has a complicated mesh, but on a hidden layer. Drawing at a scale i dont always use - several km square.
To try to fix this i will make problematic group into a componant / saveas new SU drawing and try to perform offset in a clean drawing, then import it.
Otherwise I could try scaling group to much smaller size and see if this helps…


#11

Update- I just tried the same offset in a separate file - 24kb, crashed in same manner


#12

How about sharing the SKP file that crashes with Offset so we can see and try it ourselves. Maybe we can help you solve the problem.


#13

Hi Dave, I found a work around by tweaking geography slightly, I will attach original file if you are keen to test it, this object consistently crashes SU for me, once with bugsplat . cheers SuTestOffset.skp (14.6 KB)


#14

I don’t have a problem with Offset in the file you attached.

There is that little corner toward the top left. Maybe it should be angled like that?

I do see that you have the face and edges on the layer you call RE2 instead of on Layer 0 where they should be.


#15

Thanks Dave, I usually only put groups on layers. When i tried to offset a small distance i think it worked . I was attempting to offset 400m , or 400000 units. cheers
Ben


#16

I tried a 400000 exterior offset on your file and I also got a hard crash (not caught by BugSplat).


#17

I got the crash on the PC, too, with that kind of offset.

I opened the file again and just started dragging the offset until it splatted. Sent the Bug Splat report. It would be interesting if someone on the team could look to see what the report says.

Crash Report #142061

#18

I tried 200000 instead of 400000 and this time BugSplat caught it for me. I also submitted the report.

Edit: a quick semi-informed look at the crash report suggests it is a memory management error?


#19

I forgot to look at the report. :smiley:


#20

I guess it would be smarter for me to use a different template when doing town planning type stuff- Metre instead of millimetre.
I usually am doing buildings on smaller scale, (and scaled down version of this for 3d printing) so millimetre is my go to unit of measure.
Thanks for everyone’s help with this , and now that issue has been replicated I can be less worried about my individual setup !!!,
cheers
Ben