Offset tool crashing,

I am getting a crash in Sketch up 2024 using the offset tool. Is this a known issue? Is anyone else getting this? File attached - if I draw a rectangle and offset, it may let once or twice even ten times then random crash. Lots of different files, with no common elements. Any ideas folks?

I haven’t ever had a SketchUp crash while using the Offset tool. I tried with a bunch of the faces in your model with no trouble.

How did you create this model? It uses an ancient style that hasn’t been shipped with SketchUp for more than a decade. I note that a tag called ‘_Active LayOut Tag’ is active instead of Untagged. Fixing the tagged geometry shows this:
Screenshot - 4_17_2024 , 11_23_51 AM

I suppose a crash might occur if you confuse SketchUp with differently tagged edges and/or faces during Offset…

Thank you so much for your reply, if you try and do multiple offsets on the same face do you get a crash on my model? eg, offset on the gable end, then offset again within that new offset and again, I get about four or five and then a crash everytime.
The Majority is drawn from scratch bar the 2D Cad models which are imported from a template file. I have tried selecting untagged layer and still getting the error?

Recording 2024-04-17 173817.mp4

I did all these offsets on the roof with no problem.

Thank you again, this seem to mean its something on my machine/computer that is causing the issue, I have tried deleting the ‘_Active LayOut Tag’ and all entities on this layer and still the problem persists. I am however getting the same crash on another machine. It must be me… Or something I have preset on both machines.

Try deleting all tags so ALL edges and faces are untagged as they should be. Then try again.

Out of curiosity where is the file being saved while you are working on it? When SketchUp crashes do you get a Bug Splat? If so, are you sending in the reports with something to identify they came from you?

BTW, please update your forum profile.

I have tried adjusting these but still persisting - does anything look wrong?

I don’t see anything wrong there.

You might try repairing the SketchUp installation by right clicking on the downloaded installer file, selecting Run as administrator, and then Repair. And go to the Nvidia site, get the latest drivers for your GPU, and install them. Then do a cold reboot of your computer and see if the problem persists.

I have tried deleting all tags and the problem still occurs.
The file is saves to the hardrive and backed up via one drive.
I have updated profile - thank you.
Thank you so much for your help I will try update/reboot.

Make sure you aren’t actually saving directly to One Drive.

Are you getting Bug Splats?

I am saving to a hard drive location that is within the one drive system folder? But have been doing this for 10 years and not had a problem? Is this wrong? Yes I have been filling them in

If the files are really saved on the hard drive it’s not a problem. Test that by disconnecting the computer from the Internet before trying to open a file saved in the folder.

A lot of users have reported issues with files saved directly to cloud locations like One Drive. Usually what users report is corrupted files that are often reduced to nothing but zeroes.

If you’ve been sending in the Bug Splat reports with info to identify they came from you perhaps @colin can look them up and see if there’s something they point to as a problem.

Thank you for all your help. I have done as discussed and to no avail. I have also discovered I am getting the issue on three different machines and even with a blank sketch up file. (New document) three offsets and then a crash. I can only assume it is a clash with another piece of software. I will post updates once I find out - I have also filled in numerous crash reports so hopefully can be solved somehow.

ok so full system reset - pc reset and instal Sketch up and issue is still persisting.

Can some one try this and see if they get a crash

draw a rectangle then divide with a line to cut it in half then offset one half and then select other half - offset but just by clicking to replicate the same distance as the other side and repeat two or three times?


Thank you for trying, I thought I had sussed it then but apparently not…
currently trying everything,
back to the drawing board…. As long as I don’t offset .

Thanks again.

Could you try offsetting the line with out hovering over the line, if I do what you did and at similar speed and methodically it is fine as soon as I draw at normal speeds it crashes. So I get the error when for example drawing a window . Draw rectangle divide in to small squares using line divide tool and then select each of the small areas in turn and press shortcut F, space to select next area, F repeat this at speed a few times and crash. (Think it may occur when you dont select the line your offsetting just the area - I have always done it this way?)

If not I will give up - until response from bug reports.

OK. Hovering over faces, not edges. Offsetting as quickly as I can considering I haven’t had any coffee yet this morning.

Thank you so mush for helping. Its definitely my install/machine then. I can do that no problem in 2023, in 2024 I can only do one then a crash. I have wiped one PC and completed a clean install and problem still persisting so I am out of ideas now. I will revert to 2023 for a minute.

Many thanks again for help and support