SketchUp 2017 on Surface Pro 4

I am trying to install SketchUp 2017 on a Surface Pro 4 i7 6650U with integrated graphics Intel Iris 540.

When I try to install SktechUp.exe even as an administrator, I get the following error Module C:\Program Files\SketchUp 2017\ThumbsUp.dll failed to register.

How can I solve this

Regs Fab

Search the forum for “ThumbsUp.dll” You’ll find plenty of info.

What do you mean by that exactly? Does that just mean you logged in as administrator?

@DaveR I have tried some of the solutions before, but none worked for me, hence I posted to ask the question relevant to my hardware.

I also tried to install as an Administrator.

Did you install VC++ Redistributable?

@DaveR the installation asked if I would like to have it automatically installed and I clicked yes. Shall I reinstall it

@DaveR I solved this through your suggestion.
I had to uninstall sketchup and the VC++ 2014 and 2015, rebooted the machine, then I installed VC++ 2017 and afterwards SketchUp 2017.

Thanks for the support


1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.