Sketch up app quits on startup

App has worked great for a few days. Today it won’t open. I’ve deleted and reinstalled the app. It still won’t open.
Any suggestions?

1 Like

Is this SketchUp Go in your browser or SketchUp for iPad?

1 Like

This has been happening to me for 2 days now too. I’ve used SketchUp on my iPad for free for over a year, and a few months on the Go plan. I thought it was just a me problem. The crazy thing is I can open it on my daughters iPad just fine.
Have you tried clearing the cache? I’m afraid to lose a few unfinished works I didn’t put on connect yet so I’m hesitant to do so, but if you’ve deleted and reinstalled it already maybe you can see if that could work.

Someone in another post had the same issue, and they were using iPadOS 15. Updating to iPadOS 17 solved the problem, and I know others who are on iPadOS 16 are running the app ok.

Please let us know what version you are on at the moment, and whether you can update to a later versions.

I’m using an iPad Air 2 with OS 15.8. I think it’s too old to update to 17 but I’ll try.

Thanks for responding.

Thanks for responding. If I can figure out how to clear the cache I’ll give it a try.

If it can do 16 that’s probably good enough. I had it working under 16.6.

Thanks for the response. I can’t update my iPad any more. It’s too old I guess. It worked great for about a week.