Simple operation but faces are not separating as expected


#1

This is about as simple as it gets but for some reason I can’t figure out why the following is occurring. I started in a woodworking template because I’m drawing in inch increments. I drew a 2" cube and then, using the circle tool, drew a 1" radius circle from a face’s center to an edge (along the red axis). Normally I would expect 4 separate corners that I could push/pull independently - but for some reason 3 of them are staying linked - while 1 corner behaves as expected.

I thought maybe this was an radius segment issue but as you can see in my screen shot the segment totals 24 (or 6 per quadrant), which should put the tangent point right on the cubes edge.

I can work around this easily enough but I wanted to post to see if anyone had an idea what is causing this. Been using sketchup for years and this behavior with such a simple operation has me puzzled.

By the way, even drawing back over the cubes edge from corner to where the circle hits does not separate the surfaces.

Imgur gallery with screenshots here. Keep getting an error when I attempt to embed photos.


#2

Since you tried redrawing edges, which will fix situations when SketchUp mysteriously fails to find a face automatically, it seems likely there is a tiny error that is making the vertices of the circle not actually meet the edges of the cube. Zoom in very close and see whether a gap starts to appear. If you upload your model here using

we can examine it to see whether we can find a flaw.


#3

Thanks. I can’t find an issue when I zoom so I’ve uploaded the model.

2x2.skp (17.5 KB)

I’ve been able to recreate this issue over and over - seems quite strange. I’ve heard SketchUp can have issues with small increments but 1-2" does not seem unreasonable.


#4

I can reproduce your issue, even being very careful about exact positioning of things. It strikes me as a bug. Any experts: have you seen this? Is it a known problem?

One way to work around it is to draw four quadrants between the midpoints of the cube edges using the arc tool, but it ought to work as described.


#5

Thanks - I appreciate you taking a look and confirming I am not crazy. I posted mostly because I couldn’t believe such a simple procedure was requiring a workaround.

Also, I downloaded a newer version of Make and could not reproduce the glitch so it looks like it was fixed sometime between versions.


#6

It appears to happen only with a certain combination of Units settings. Switch to Decimal Inches and it does not happen.

So it is a glitch when Fractional Inches are selected and the Precision is 1/64".


Weirdly, it does not happen when you use Polygon with 24 sides.


#7

I tried with decimal inches, 0.000000 precision, and it still happened! Looking at the outerloop of the problem Face, it really does return to exactly the same Vertex location at the “point” between the sections.


#8

Yea, it is glitch-y. Seems to happen or not, also depending upon whether length snapping is off or on.

Hard to make sense of.


#9

If the polygon tool works and circles are really polygons, why do we need the circle tool?
Tongue slightly in cheek,

Shep


#10

I believe the difference is the circle tool welds the segments and will export as a true circle in 3d mode.


#11