Simple DXF Bug Splat on Explode

Good Morning, I am a relatively new SketchUp user and find it tremendous. I was trying to import and then explode a 2d plan when I continually received errors trying to explode the drawing. after trial and error for a couple of days, I could isolate the problem layer. I assume it must have something to do with geometry but I am not sure what I am looking for.

This plan originated as a PDF that I then converted to DWG/DXF. I would appreciate any insight into this issue as I have another 4 of these to do each with many layers.

I have looked at the other posts with this issue but could not find a resolution.

Thank you very much.

Norm
836 Main CAD IMPORT PL3 DXF.dxf (297.5 KB)

It imports and explodes ok for me. What errors do you see? Can you add your SKP before you explode, so that we can try it.

Two things to keep in mind:

  • change the width of the lines in the dxf file to 0, otherwise, when you import you will have such a geometry

frd-06

  • normally you use the dxf file only as a base, you don’t have to expold it, and you build your 3D model in SketchUp, based on it.

Thank you Colin, here is the SKP

836 Main CAD IMPORT PL 3.skp (136.2 KB)

Thank you Mihai, I will change the line width. If I leave it unexploded I would then scale and “trace” the walls in SketchUp is that right?

Norm

I still get no errors. Maybe you mean that you see things wrong in the model, and you don’t see error messages. If that’s the case, what Mihai said could be the solution.

You’re welcome, Norm!
After preparing the dxf file (line width to be 0) and importing it into SketchUp, assign a tag and then lock it. Then add walls by tracing over or other methods.

Your skp file (not indicated method)
frd-06

It is definitely a bug splat. Only in one file, If you can explode it then it must be my environment.

I think I can move forward with that layer unexploded.

Thank you again.

You mean width. Thickess refers to the Z dimension. A wide polyline with thickness produces a “wall” when imported to SketchUp.

1 Like

Thank you, Anssi!

I did manage to eventually get an SKP export from MicroStation to open and explode in SketchUp. Now however I see what the other comments were referring to. The resulting exploded file is quite a mess. So I suppose tracing would be best.

Norm

It seems to be a Windows only crash, that should be fixed when the next update is released. Can’t give a date for when that will be!

Meanwhile, here is your floor plan exploded, even if you don’t need it now!

836 Main CAD IMPORT PL 3 2020 version.skp (856.5 KB)

By the way, Niraj is about 5 foot 9 inches tall, I think your floor plan needs to be scaled up.

The default import unit is Feet. Was the model created in Meters? The import unit can be changed in Import Options (button on the Import File dialog)

Thank you, Colin. I am 5’ 9" as well LOL

Norm