Shell of follow-me extrusion doesn't disappear with layer

I have created a cable with some wires on a “cable” layer. When I hide the layer, the shell of the wires don’t disappear. I can confirm they are on layer “cable”.

Here’s what it looks like when the cable layer is visible:

When I make the cable layer not visible, I get this:

How do I get the visibility of the shapes created from follow-me to be controlled by layer visibility?

2 Likes

Can you share the skp file? It sounds like incorrect layer usage.

2 Likes

Seems it’s too big to upload. I’ll try to simplify.

Or upload it to Drop Box and share the link.

Better not to disturb anything.

1 Like

Ok, but on a hunch I tried moving the wires into the “cable” component. They were instanced at the top level. So, I moved them to layer 0 and redefined the cable component to include them.

If that doesn’t fix it, I’ll use drop box.

Thanks.

(It takes several minutes just to create a component)

The geometry should have Layer 0 assigned to it and only groups or components should get other layers assigned to them. (Nothing in SketchUp is “on” a layer.)

1 Like

That could be the problem, then. But I thought the layers were used like tags and that a typical issue was that a shape would not be visible when expected since visibility in a shape required not only its layer, but its container’s layer to be visible also.

This doesn’t fit that. But, I DID break the rule of having shapes not in a component or group on something other than layer0.

I’m loosing patience waiting for the component to get created. I’ll report back tomorrow–I might have to close SU and redo the new component definition. The model has just gotten to big, I need to focus on simplification, I think.

Moving the shapes to layer0 and making them part of a component didn’t fix the problem.

The component is on layer Cable. When I make Cable layer not visible, the shapes remain visible.

When I hide the component that’s on the Cable layer, the shapes become invisible.

I don’t have a dropbox account. Tomorrow I’ll register for a free trial.

Never used drop box before, but here’s a link to try:

That’s a large file, too large for me to download on my metered connection.
Try making a copy of the file, then go to Window/Model info/Statistics and click the Purge button. Then save it and see how big the file is.

1 Like

I did download it, you need to keep your models clean.
I purged this from your model and reduced it from 180mb to 38mb.


You should also model with Profiles turned off. View/Edge Style/Profiles

You do have some geometry on wrong layers, but having cleaned your file I can’t find the specific issue you were looking at.
I’m not sure what the roughly 4000 components that are still in your model are, but I don’t have the time now to look further. I would suggest you purge your version and upload that for Dave to look at when he has time.

2 Likes

Box is right. There’s a lot to clean up. I corrected the incorrect layer/tag usage…
Screenshot - 9_26_2020 , 5_07_35 AM

And purged unused.
Screenshot - 9_26_2020 , 5_08_43 AM

Then I selected the cable component and gave it the Cable tag/layer.

Turning off its visibility in the Tags panel then works as expected.

2 Likes

Can you tell me what you did?

On one copy I used that extension but later I decided it was not longer needed. It seemed you can just delete a layer and SU asked where the shapes on that layer should go.

So ,I deleted all layers one at a time and responded anything on them should be moved to layer0.

And I don’t understand why nothing show up (except those shapes) when nothing but layer0 is made visible?

I’d also run cleanup3, several times, does it not descend the component hierarchy?

Didn’t know about purge!

I’m doing the purge now, will run the TIG extension when it finishes.

Yes, simpler models would speed things up. It’s always a trade off between the time to do the models (versus simply import them) and the performance impact.

The trade-off is different depending on skill level. You guys are obviously experts. I do this only a few times a year, for two or three days. Still, my next step was to look for “low hanging fruit” like the screws.

Also, it sort of defeats part of the purpose of my 3d model of enclosure components. Those are THE screws I have ordered for the assembly. Their lengths have to be just right so that the engage the threaded spacer from both ends, yet don’t bottom out on each other. Sure, I could model them the right length, but part of what the SU model does it provide a check that the mechanical parts fit as expected. For example, I could misread the spec and confuse overall length with length under the head. Just a trivial example, but the point is not to just get a model, but to verify fit.

I’ll report back when the purge and cleanup complete.

Thanks!

The only shapes not in a component in the first SU file I uploaded were those that didn’t disappear when I disabled all layers but layer 0 (they were on layer Cable).

I changed them to layer0 and moved them into the Cable component. Then when
I turned off all layers but layer0, everthing disappeared but the shapes I posted. Doesn’t that mean they were on layer 0?

Not sure its worth investigating more, if the TIG extension fixes things, but if it’s an easy answer, I’d like to understand what was wrong.

Not really–just hadn’t finished aligning them yet.

BTW, that’s a pita. Suggestion for an easy way to do it?

Note the blank tag label when I triple click the wires.
Mixed tags

2 Likes

So, that blank tag should have been layer0?

The TIG extension not only moves from other layers to layer0, but also assigns geometry with no tag to layer0?