Shadow conundrum

Hi! I have a very frustrating issue. I cannot get my shadows to work properly. Sometimes they flash on for a second and then its goes back to ‘dim’ and sometimes I can’t get them to work at all. They are not pulling through to LO. I really need to hand in a course assignment and at the moment all my scenes are shadowless which looks a bit unprofessional. Help v much appreciated.
Screen grab of my SU settings and then also the LO image.

I don’t think my screen shot attached, here it is:

Looks like you have a ceiling between the sun and the rest of the space.

Share your SketchUp file so we can see the exat set up and help you out.

1 Like

It’s a pretty big file…
Here’s a dropbox link!

Well, I’m getting shadows but even with my discrete graphics card it’s slow. Your profile indicates your graphics card is “memory”. Does that mean you have an integrated GPU?

I set the face style to Monochrome and turned offProfile edges to speed things up. Note that the floor in the living room has its back face up. There are other exposed back faces, too. These can cause problems in rendering and should be corrected.

FWIW i did my usual cleanup exercise on your model. I fixed incorrect tag usage …
Screenshot - 1_30_2023 , 9_55_02 AM

… purged unused stuff …
Screenshot - 1_30_2023 , 9_55_39 AM

… and resized 37 exessively large texture images. There a ficus bark texture that is 5000 pixels wide. Certainly the bark on a ficus tree doesn’t need to have that kind of resolution. That cleanup reduced the file size by almost 45%. More could be done to reduce the file size so your computer doesn’t struggle with it.

Hmmm I started it before I realised the importance of checking the size of stuff I imported from 3D warehouse (its my first proper design) and now I’m regretting it!! Im sorry I’m not sure about GPU, I don’t think I have one? I have a desktop iMac.
May I see the cleaned up version or is that not the protocol?

This is a common enough problem. You aren’t alone.

Think of your SketchUp project as having a budget. The size of the budget depends largely on the capabilities of your computer. It also depends on how much time you are willing to invest waiting for your computer to process whatever you are asking of it, such as turning on shadows. Every edge, face, and texture come with a cost. Just as in a real project with a real budget n money terms, you need to consider where you invest. For example, do the Gaudi and Picasso books on the shelf really need a front cover image? They can’t be seen when they are in place on the shelf. Maybe none of the books need any cover images. Maybe they’d tell their part of your story with simple colors instead.
Screenshot - 1_30_2023 , 10_24_54 AM
There’s plenty of similar examples to be had in your model. For your next projects, at least, give some thought to slimming down the components before you add them.

There must be a graphics processor of some sort or you wouldn’t be able to see anything at all on your computer.

Certainly you may. I hadn’t gotten it uploaded to Drop Box yet. Here’s the link now, though.

You’ve been so kind, thank you.

The document is much smaller now, thank you. However I am still having this shadow issue. It comes on for a second when I click a face and then disappears. The shadows don’t pull to LO. I have attached a little screen recording. I’m so grateful for your feedback!

Do you have the ceiling faces removed?

no they are not removed :frowning: This screen grab is the version you sent me with the ceilings intact

The ceiling geometry in your model was tag incorrectly and appeared with correcting that problem. Delete the ceiling faces and see if that helps. If you must have the ceiling faces you can paint their top sides with a totally transparent material, too.

Here I’ve deleted the ceiling face and turned on shadows.

And in
this version I painted the top face of the ceiling with an color that I then made totally transparent. The celing color shows from inside the room but the light from the sun is able to penetrate.

1 Like

Ok I will try this thank you. So I know for future, does having ceilings always make the shadow took defunct?

Well, the shadows come from SketchUp’s “sun” so as in reality, a ceiling blocks the sun and you don’t get shadows inside.

1 Like

The first screenshot is from a Mac. Most of them use onboard graphics.
In the first screenshot you posted,

  • shadows are not visible because “use sun for shading” is turned off. This means that all light is coming from a “torch mounted on your camera” so you won’t see them
  • check that your location and the time zone you use match

Dave’s advice about painting the ceiling faces with a transparent material from the outside is good. For an interior scene, I would choose less dark shadows to give a more ambient feel to the light.

1 Like

thank you, very helpful :slight_smile: