Shadow animation looking wonky

So I was doing a simple example of shadow analysis on my project and decided to animate the scene. Between 4 scenes with a 7 second transition the video plays for the expected 28 seconds, however, there is a point in the video where it seems as if it almost jumps to a previous scene and then re-plays that section of the animation.

For instance, I run from 01/05 at 5pm to 05/05 at 5pm to 08/05 at 5pm and finally 12/05 at 5pm. the 01/05 and 12/05 are close enough that the day-cycle should start in roughly the same light and end in roughly the same light.

I understand that the sun changes as it rotates around the planet and you can see that here roughly half way through the video.

The weirdness is at roughly 20-21 seconds.

Video

https://forums.sketchup.com/uploads/short-url/rq0aTMELKrJObeoJrMGM79KwXUO.mp4

Here is the link to the .SKP on the 3D Warehouse if that’s needed.

3D .SKP

https://3dwarehouse.sketchup.com/model/61960323-401d-4203-aa3c-8c0882f82a20/SandcanyonURBPproject6

Any help would be greatly appreciated! Thanks so much.

Here’s the model you shared at the 3DWH.
There are only 2 Scenes in the model.
Both scenes have the camera positioned inside the terrain box.
Perhaps you uploaded the wrong model?


I might have. Let me upload it again, sorry.

Ok, I uploaded it and when I try to download it from the link through my browser:

there are some issues that arise. I have to install the 2017 version of this file. It should be named ‘upload scene for forums’.

Let me know if this doesn’t work. Additionally, the scenes in question are the only operable scenes for animation. You’ll likely notice I have 400-ish scenes but only 4 of them are actually enabled.

Thanks and sorry for the trouble.

Here’s a live link to the model:


I’m not sure what I’m doing wrong here. This is what I see, which isn’t the version you’re seeing.

This is the most recent and updated file. How are you even getting the old files I have uploaded in the past?

OK, I think we finally have it.

1 Like

It’s nighttime in two of the Scenes.
The Sun has already set at 5pm on 01/05 (January 5) and 12/05 (December 5)

The dates in the scenes are out of chronological order, which doesn’t make sense to me.
• 12/5 at 5pm is past sunset
• 8/5
• 5/5
• 1/5 at 5pm is past sunset

What’s the point? The model is not geo-located.

It’s just to show that we can use the skill, which we are geolocating in the next class. The issue here isn’t that two scenes are past sunset but that the animation hiccups or jumps, seemingly to another date/time at around 20 seconds. I uploaded the animation clip in my original post to illustrate the problem.

Again … The dates in the scenes are not in chronological order.
And if one arranges the scenes such that the dates are in proper order, the first two scenes are nighttime.
If you want the animation to make sense, try not forcing it to go backwards in time.

1 Like

I’ll check that out but it’s a gradient from 12/05 to 01/05 so it shouldn’t have hiccuped going backward in time but I’ll let you know if changing it around to go forward in time makes a difference.

If I change it to chronological order, however, it would be 01, 05, 08, 12 and it wouldn’t be night for the first two scenes either. I’m not sure why you think that. All of the scenes are 2017 as far as I can tell. Unless I missed something.

The animation still jumps even after I sorted it from January to December. What now?

Hi Alex,

Here’s an MP4 wherein the shadows run smooth from 1/5/17 thru 12/5/17

The animation is comprised of just two Scenes
The first Scene is 1/5/17 at 5p
The last Scene is 12/5/17 at 5p
Scene Transition time was set to 28 seconds and Scene Delay 0 seconds

The 5/5/17 and 8/5/17 Scenes were deleted.

The model was manually geo-located and all scenes not used in the animation were deleted. Drawing Axes found away from default position in Scenes were reset and Scenes updated.


1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.