Shading broken?

Most likely I’ve got a setting here that I don’t know about, but I have two models that I have explored extensively for setting differences and I cannot find anything. Of two test models, I have a “broken” one and a “normal” one. The “broken” one used to have a very complex model that has been completely deleted but continues to have strange shading “corruption”. The “normal” one behaves, well, normally. The difference is best seen by example…broken comes first:

And the “normal” model shows this:

Since I can find no discussions on this issue, I am assuming this is pilot error and not a bug. But I’m not a rank beginner and this started when I upgraded so I’m also suspicious that it might be a bug.

If you upload the one that doesn’t work we can check it.

Have you played with Fredos new plugin?
https://sketchucation.com/forums/viewtopic.php?f=323&t=71816#p654390

Yes, it’s a user’s error, not a bug.
In the ‘Shadows’ window there are two sliders that you can play with, to adjust how you’ll see the different oriented faces. Also here see what ‘Use sun for shading’ will do for you.
Once you have setup these sliders etc. save a scene to return to. They will be (can be) saved with the scene.

b.t.w. there are no edges where you imply them to be. It’s just two faces crossing, not intersecting yet. You can select all crossing faces and apply ‘Intersect Faces with…’ > "with Selection’ to get the real geometry, the edges that mark the folds.

Is your display style set to Hidden Line?

That looks like exactly what happened, but I turned off all the extensions I use (disabled) and the problem persists. I will upload the model.

BINGO. Pilot error! Another Sketchup user humiliated. Thanks everyone, but most of all, you g.h.!

I had checked all view options (including the sun), but never thought the sun could be “on” while shadows created by the sun were “off”…very strange why someone would want that…

Problem resolved!

1 Like

I use that frequently when I want to show faces shaded but not from the camera position. Especially when I am making image exports for composite images. And the flat color thing can be achieved by turning on Use sun for shading and reversing the light and dark sliders. No need for an extension to do that.

I am aware of this, and although I definitely shouldn’t call them edges at all (they are not), they do perform like edges as far as picking up inference points. And without the visual, it was driving me nuts.

Thanks again for the “sun/shadows” tip.

Not really, I didn’t learn SketchUp overnight and mind you, we have all been there. So don’t see it as being humiliated, but just my guess leading to a solution.