Server Error Downloading Update

Just trying to make SOMEONE WHO CAN FIX IT aware that it is currently impossible to download updated versions of SU Pro. I realize that Trimble would love for all of us on-prem licensees to go away, and they have made it as difficult as humanly possible to contact the company about SU without clicking through layers of baloney on the website (How about a simple email address NOT a stinking web form ?) But this is ridiculous. “Internal Server Error”? sending an ugly error page… What is this… 1995?

See Screen below.

Not sure where you clicked through to get to this page, but when I go SketchUp’s download page, this is the web address for the 64 Bit, Windows, English download:

And the download works - no problem.

Thus I think you might be the victim of a bad or malicious link - linked from someplace other than the official download site.

Wrong. Your link is exactly where I started. There was nothing wrong with the page, no “malicious links” or other VooDoo. I’m not an idiot, and we are very well protected. FWIW - it’s working now. Possibly someone fixed the server configuration?

Which is why I said: “I think you might be …” (emphasis added).

It still might have been a glitch (malicious or accidental) in your DNS server. It could have been hijacked earlier - and resolved when I tried it (and when you tried again).
I’m sure that if it was something misconfigured, then corrected at Trimble (SketchUp), someone who works there will (eventually) see this thread and post an explanation.