Download not working


#1

This download link doesn’t work, says This webpage is not available.

I’m using latest Google Chrome on latest OSX.


Cant download Sketchup make
#2

all downloads = download server down


#3

SketchUp Product Downloads

http://www.sketchup.com/download/all


#4

Yes the download all page is there, but the download link on that page isn’t working.


#5

I am getting same problem for windows


#6

Same here, but for the Windows file. I’ve gone to the “download all” page and the main download page and both aren’t working. It seems like “download.trimble.com” is down (I tried pinging it and it couldn’t be found).


#7

Seems like a DNS glitch - I also can’t find the server.


#8

Please retry, and report here if it’s working now. Thanks.


#9

Hi @Barry
I just tried to download SketchUp Pro 2015 Windows 32 Bit from here:
http://www.sketchup.com/download/all

The link…

http://download.trimble.com/sketchup/sketchuppro-en.exe?Expires=1434032049&Signature=DGo0Sn2MVAtkDQzrDbhpoGQnKGJAEmnLQMgLuDJK7os5O8QH91vs0Vo93~m--jH8bidszE4u~eAZawh-HdiJVDkRiNIOArpmGZy1Mmj~4AsKlimP4VuX2J4e1hLNC3mMzz3olvNFWyy~NLtwOBSzSMuxMMzdHolulszhcq3hVzs_&Key-Pair-Id=APKAITRMO3ODNM6MFOEA

Yields this…


#10

Yet for me, FF from a southern hemosphere server on every download link now I get something equivalent to this.


#11

works
.
.
.
.
.
.
. here.


#12

I am trying to download SketchUp Make, but keep getting errors that the download page cant be found. is there a problem with the servers or is it being blocked?
Thanks


#13

i have been having the same problem.


#14

There appears to be a server problem at the moment.


#15

We had a DNS issue last night, so if you know how to clear your DNS cache, please do. If you’re on Mac

OS X Yosemite
Use the following Terminal command to reset the DNS cache:
sudo discoveryutil mdnsflushcache

OS X Mavericks, Mountain Lion, and Lion
Use the following Terminal command to reset the DNS cache:
sudo killall -HUP mDNSResponder

For details see https://support.apple.com/en-us/HT202516

For PC, pipe up, because I’d just do a Google search that you can do yourselves.


#16

I did the cache flush as @Barry suggested, and I can see the download host again (I’m on Mac). Just tried a download and it worked.


#17

On good authority for PC:

Open an elevated command prompt and type:

Ipconfig /flushdns


#18

One teeny tiny caveat on Mac, if you’ve happened to upgrade to 10.10.4 beta: they reverted back to the mDNSResponder-style of Lion-through-Mavericks versions, so use that command instead of the Yosemite command. I don’t know if this will officially be used in the final version, so don’t write this in stone. Carry on.