Scaling one object to a specific measurment

attached is the file. Here is a photo of a curve i have made, it sits 50 units above the top surface of the faceplate below it. it needs to be 126 units from one end to the other, scaled proportionally, the ctrl modifier basically. Is there a way to tell it to scale to 126 units in that direction while keeping it proportional? I could use the proportionality theorem(75.6/1 = 126/x) which is not hard but wondering if there is a way to tell SU to do it for me?

i did try to use the tape tool to scale it but it resizes the entie model which i do not want:)

curvi loft practice.skp (1.4 MB)

if you group the entities and then edit the group, the scaling with the tape measure will only affect the entities in the group.

1 Like

thats good to know. like really good to know. Saves me alot of time doing that.

1 Like

ok, alot of times the tape tool creates a line or the mark rather than scaling it. why does this happen?

ok, i tried it out, and it works, but makes it off center, anyway to keep the scale about the center with the tape tool so i dont have to move the object?


I don’t think so. You would need the scale tool to do that.

1 Like

ok, perfect:) so with the scale tool, anyway to make it scale to a measurement or is there an extension for that? i mean, it took me 5 seconds to do the math, but i dont always want to haha

The scale tool allows you to scale to a given size - just type in the dimension(s) you want it to end up as, INCLUDING THE UNITS - for example, 6", 45’ 2 3/4", or 6.57m, etc. If you are scaling in two or three dimensions, enter both or all three dimensions.

To scale about centre, tap the Ctrl key (Windows) or Option key (Mac) and the centre scale handle will turn red. Tap again to turn that off (in the latest version of Sketchup).

In earlier versions of SU, the modifier key only applies while held down.

1 Like

Select your shape, invoke the scale tool. Grab one side handle in the direction you want to set at 126mm. Hold down both shift and option (control key on windows) at the same time to get scale around center and scale uniformly (shift) both working. In 2021 these became toggles but in 20 they need to be held down. Move in mouse a bit and click to finish the move. Then type 126mm. This will make the scaled direction equal to the entered measurement and the rest will be scaled proportionally around center.


The Control key toggles create guides on and off, make sure the plus sign next to the tape measure is off before attempting a resize.


I use 2017 Make and the way I set the specific resize with native tools is by making the item a group or a component. I then double click to edit and using the tape tool select the start point and the modifier key and then select the end point. The dimension will appear in the measurements box in the bottom right of the window. I then type the dimension I want and am offered the option to resize the group or component and click yes and it’d done. No fancy maths or drawing extra lines.
If you don’t open the group or component and you use tape tool in the same way you are offered the option to resize the model - not what you want.

1 Like

when i try this method, it moves the group off from center. Then i have to move the new sized group back to center point when it is resized. in your gif, it looks like it keeps it centered. Is there a another thing i have to do to keep it centered?


If you make a component instead of a group you can place the component’s origin in center and then it will stay centered.

so why do components stay centered but not groups? Or do you mean make a copy of the component and then scale it?


A group would stay center IF it’s origin was in the center.

Some people won’t use components, though.


yup, mine does not do that at all. mine goes off to the left for some reason. The profile is exactly centered at the orgin just like yours and it goes off, the mark.

Let me restart the software and see if that helps…

When you double click to enter the group to edit it, where are the axes for the group?

1 Like

not scaling the orgin
shows them not at the orgin, even though on the outside, they are…

The model axes are centered but you didn’t center the group or component axes as I told you.

Watch my GIF again. The model axes are off to the side but the component’s axes are centered.

1 Like

how the heck do you change the axis? haha

If you’d make a component instead of a group, like this.

1 Like

thanks, that did the trick.

Also thanks to others whom showed me how to use the scale tool with a specified measurement.