Scale Drawing Slow Performance


#1

Hi. I had high hopes for the new “Scaled Drawing” feature in Layout 2018 for doing scaled detail overlays to construction sections etc. I am finding myself continuously frustrated by it’s slow drawing performance however, even with very simple line drawings and geometry. It’s is nothing like the drawing performance in Sketchup.

Does anyone have any experience optimising drawing settings or techniques to make it draw more quickly in scale groups?

I running 18.0.16976 on a Macbook 2015 2.7 GHz Intel Core i5 with Integrated Graphics, OS 10.3.3


#2

Scaled drawing by itself should not be any slower than regular drawing in LayOut, however there are some situations that can be slow.

First, if you start a new LayOut document and immediately start doing a scaled drawing, is the performance faster?

If the performance is fine in a new document, then then next step is to be careful about what else is visible on the page where you’re doing the scale drawing. Because of the way LayOut greys out the rest of the page during any type of group editing, performance can suffer if there are big images or big vector/hybrid rendered models on the page. If possible, temporarily hide the layers containing any unnecessary big items. Alternately, use the “View->Group Edit->Hide Rest Of Document” setting to do the hiding for you.

Let me know if anything works for you.
-m


#3

Yes, when I start a new layout document it is definitely smoother and quicker to do drawn line work. And yes, the slower performance happens with regular groups as-well as scaled drawings.

For my workflow it is often necessary for me to “draw over” model views, and so “Hide Rest Of Document” isn’t a helpful option. What render mode should be most efficient; ie raster, hybrid or vector? Can I turn off the greyed out geometry as a setting, if it’s a performance bottleneck? And finally, I have integrated graphics in my laptop, would a dedicated higher performance graphics card make a difference in this instance?

Thanks for your help! Justin


#4

Your mileage may vary depending on your exact model, but raster is usually the fastest option.

There’s no way to just turn off the greyed-out portion of the background, the setting I showed you is the only control that’s currently available. We’re looking at ways to improve this in the next version.

I wouldn’t expect to see a huge different with a more powerful video card - this is not so much a horsepower issue as it is a memory bandwidth issue. You could see some improvement but I can’t say how much.

thanks,
Marc


#5

For what it is worth, you cannot turn off the greyed out portion altogether, but by setting slider all the way to ‘Darker’ performance is a bit better.

Trent


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.