Scale Drawing in 2D


#1

I am a very very newbie user and want to know how to draw in 2D to scale, for instance 1/4"=1ft, or 1"= 1 foot, and full scale 1:1… I draw small things in 2D with lines.

  1. When I open a new drawing page and draw line that’s about 1" on the screen, it measures 20ft in the program…? I can magnify and keep shortening the line until it reads something reasonable… but that’s a lot of trial and error…
  2. It would seem to me that you’d just tell the program that you’re drawing in, for instance, 1/2" scale and then start drawing…?
  3. I read about the “Layout” mode, but can’t find it… how do you enter Layout? Do I need to be there to do the simple line drawings I want?
  4. Maybe I have the wrong Program? Can anybody recommend an inexpensive, simple 2D program that is suitable for floor plans?

#2

You can draw 2D floor plans in SketchUp if that’s what you want to do but you could also make a 3D model from which you can extract 2D plans and elevations.

If you wish, you can draw 2D plans directly in LayOut, too. There you can set a scale for your dimensions. I think it’s a whole lot easier to draw in SketchUp and send the scenes to LayOut.


#3

SketcHup is a full scale surface modeler. There is no scale. You model at real size.
Zooming is/out lets you see the model in detail/overview.

You can set up scenes in ‘Parallel View’ with the ‘Standard Views’ in SketchUp and send the model to Layout. There you can pick up the scenes at certain desired scale for printing.

SketchUp itself has limited options to print to scale.

b.t.w. The screen at ‘correct’ scale after zooming in/out would be off scale again with another larger or smaller screen. Adjusting to scale on screen makes no sense.

p.s. Smartdraw (http://www.smartdraw.com/floor-plan/cad-drawing-software.htm) is a cheap drawing program more suited for your 2D floorplans. Or you might want to try Layout. that comes with SketchUp Pro.
There are other (free) programs, see: https://sites.google.com/site/sketchupsage/resources#TOC-Other-Modelers


#4

Note that in LayOut you can only draw to full scale on the sheet, so you will have to calculate the length of every line in your head or on a calculator if you want to draw to a scale. The scale settings apply only to SketchUp model views that are using Parallel Projection. It is truly much easier to draw everything in SketchUp, whether 2D or 3D, and use LayOut only to annotate and publish the drawings. Even if LayOut is a standalone application and not a “mode”, its functionality is very much comparable to the Paper Space view tabs in AutoCad or sheets in BIM applications like Revit or Archicad.

Anssi


#5

When I draw a line and label it 10" long it shows up on the screen as tiny dot. Window-Zoom has only 2 settings, once in and once out, and neither makes any real difference in viewing. Camera-Zoom has some zoom settings but they don’t seem to just make the tiny dot on the screen any bigger…

I just want what I am drawing to appear on the screen big enough to work with…?


#6

Try the zoom-extents tool:

(also by default shortcutted as shift-Z)


#7

Thank You! That did the trick… It makes that 10" line fill the screen. Just what I wanted. That way if I am drawing to a 18x24" page, I can draw an 18x24 box and Voila! …a page to work with! Is this Sidney BTW?


#8

Nope, I’m a Steve! By the way, if you have a typical size model you work with, you can draw something that size, zoom extents on it, delete it, and then save the result as your default template. Thereafter your default template will open already zoomed to that size.


#9

Thanks Steve… Sidney is a landscape architect in town… Your help is very much appreciated. I think the next questions will revolve around printing from my I-Mac to the Canon MX 88w Ink Jet printer. Typically I draw parts up full scale, and take them to the shop… My initial test were not successful, although the page set up and printer options are limited…

…Lander


#10

This is a very common question. It is easier using Layout, which is part of the Pro version of SketchUp, but with a bit more effort can be done using SketchUp Make. This topic links to several tutorials on how to proceed:


#12

Steve… stumbling around, I discovered that taking a screen shot (cmd-shift-4 on the mac) of the drawing seems to reproduce it 1:1… go figure… Then I can PDF and reproduce, or e-mail it, or whatever…


#13

Can other Mac people duplicate @SecondWind screen shot technique of printing-to-scale? I would like to add this to the SketchUp Sage’s print-to-scale tips.


#14

Steve… I tried it again with another drawing and I think I just lucked out…kinda close, but not really. Maybe somebody more talented than I can work this into a science, or there is another way to print full scale details…


#15

Another way, Geo’s Print to Scale


#16

I was surprised at the screenshot technique, as a screenshot just captures pixels it doesn’t know anything about physical size. As you say, probably just a lucky accident! If you export from SketchUp as a 2D pdf, I believe you can get exact scale from something that knows how to print pdfs though.


#17

I use a page template that is 8.5x11 and if I hold the screen shot cursor “about” 1/4" from the edge of that, and select it, it is pretty darn close…highly scientific… :slight_smile:

So, your thinking to save as PDF and then print? Worth a try!


#18

I tried Exporting to PDF and printing from there, but it does not print 1:1, as in being able to use a measuring tape on the drawing. So, after a bit of trial and error I included some guides on the SketchUp drawing, in the form of 2 squares in the corner. If I set the Screen shot cursor on the inside corner and drag to the other inside corner, it produces a drawing that is pretty darn close to being measurable, within 1/32 anyway. I attached the file, because hopefully a picture is worth a 1000 words…?

Speaking of 32nd’s… Can SketchUp get closer than a 16th? I would love to get down to a 64th, especially for hole drilling sizes…
Armature Top Plate 1~.skp (99.1 KB)


#19

It sounds to me like you’re working too hard. And maybe trying to run before you know how to walk.

First, in SketchUp you can adjust the precision of your drawing and dimensions under Window>Model Info>Units. If you’re working in fractional inches, set the units to Fractional and set the precision to 1/32 or 1/64. I prefer to work with precision at 1/64" because it makes it easier to find incorrect dimensions.

After you create an appropriate scene in SU and send it to LO, set up the scale correctly and export to PDF. Keep in mind there are scale settings in Acrobat/Reader that impact how large the PDF prints out. It may be that your drawing didn’t print to scale because you had the incorrect scaling option selected in Acrobat or Reader.


#20

SketchUp works to high precision internally, but depending on the settings in Window->Model Info->Units it may display rounded off values and may snap lengths to a specified interval.

One thing to be aware of if you work with small parts and close tolerances is that SketchUp has a “clean up” operation that merges vertices when they are closer together than about 0.001". This can cause loss of edges and their associated faces when you have tiny details such as edges in arcs or circles. The workaround is to scale the model (or a ComponentInstance) up by some factor, do the drawing of the small features, then scale back down afterward.

And once again “slow” Dave beat me to the post :grinning:


#21

If you want to use SU you can adjust with ruby code…

Sketchup.active_model.active_view.zoom_extents.zoom(1.051)

play around with the 1.051 until it matches your Printer - Print Borderless output…

once it is accurate for your printer, always use that number…

john