Sandbox Tools License

Every time I open SketchUp Pro 2021, I am notified that there is “one extension license issue.” in particular, it “Failed to obtain active license for Sandbox Tools. License missing.” The tools are working, but it’s a minor nuisance to have to dismiss the warning every time. I’ve tried uninstalling, updating the license, installing over the existing extension (because uninstalling apparently does nothing.) I’m out of ideas. How about y’all?

Most probably, you’re not signed in currently with the email that bought it.

Thanks, Mike. I checked: same email address. Sandbox Tools comes as a part of SketchUp, though. If SketchUp is happy, shouldn’t Sandbox be happy as well?

Did you install SketchUp correctly? On Windows that would involve right clicking on the downloaded installer and choosing Run as administrator.

I thought you where talking about the bonus tools

Did you ever install those?

Thanks for the idea, Dave. Truth is, I don’t recall. It’s been months since I installed it. (It’s a program that I use intensely for a while and then not at all for a long time.) If all else fails, I might unlicense this computer, uninstall SketchUp, and start over; but starting over would really be a last resort. It just seems like opening a can of worms, begging for something else – maybe something far more problematic – to go wrong. It would probably be better to disable Sandbox except for the rare occasion when I use it since everything else, including the actual Sandbox, is working properly.

I never did, Mike.

How about starting a little more easily? Go to and get the latest installer. Once it is downloaded to your computer, right click on it, choose Run as administrator, and then, if prompted, choose Repair.

You should not have to unistall it, just sign out via the help menu, close Sketchup and start it again.

Ah, now there’s a plan I can live with. Thanks.

1 Like

Thanks. I’ll give it a try.

Thanks for the ideas. I’m sorry to say that neither worked.

It sounds like at some stage you installed the non sketchup team Sandbox Bonus Tools and the trial has ended so it is looking for the license. Have a look in Extension Manager and see if it is there. Or look in the Plugins folder and see if there is an entry for it there. If there is you can just delete it and it should stop bothering you without effecting the normal Sandbox tools which you say are working.

Thanks for the thought, but it’s not in the extension manager or the plugins folder. My next thought is to disable every extension except Sandbox Tools. If that works, then I’ll add the others back in to see if I find one that is interfering.

Found it! The culprit is NVIDIA’s Omniverse extension. Don’t need it, happy to uninstall it. Not happy that I now have to rearrange all the toolbars.

Well there’s a thing we never could have guessed at.

1 Like