Running Sketchup on a Linux machine


#1

I’m a serious Sketchup fan for quickly creating objects for 3D printing. My only gripe is that I can’t get it working under Linux and I resent having to re-boot into Windows every time I want to use it! I’ve tried Wine, Crossover Linux and even running it inside a Windows virtual machine but none of these have worked for me.

Has anybody successfully run Sketchup in a Ubuntu-flavoured Linux environment? I would be very grateful for advice from somebody who is actually using it this way!

Thanks,

ChrisB


#2

emulations can be difficult but a virtualized Windows by using e.g. VMware should work in any case. If using a lame video card (aka integrated/shared) you might be required to disable “Window > Preferences > OpenGL > Use Hardware Acceleration” to avoid video output glitches.


#3

Thanks for your reply. I think you’ve correctly identified my problem - I’m trying to use the integrated video card in my laptop. I will try the virtual machine approach again with Hardware Acceleration disabled.


#4

That’s fixed it! I just turned off 3D and 2D video acceleration and Sketchup appears to be running just fine in a Windows 7 virtual machine using Oracle VirtualBox.

Many thanks sketch3d_de!


#5

Hello ChrisB, I was wondering which distribution of Linux you’re running, and which version of Oracle Virtual Box did you install to solve your issues?


#6

Hi Dave, I run the Mint Mate distribution, and I would have been running whatever version of Virtual Box was current in May 2015. I’ve updated it since and I’m now running v5.1.34

Unfortunately I’ve not run it for a couple of years so I don’t think I can be much more help!


#7

Hey ChrisB,
Thanks for the reply. Do you still use a CAD/CAM application in Linux?


#8

No, not right now. I was using Sketchup to draw 3D models for 3D printing, but my printer has been sitting under the bench for a couple of years now. I must get back to it some time!

ChrisB