Right Click Context Menu Disappearing

I think this is a bug, but I could be wrong. Very often, enough to be super annoying, when I click on an object and then right-click to bring up the context menu, it appears for a split second and then disappears again. I usually have to repeat this process 3 or 4 times before it steadily appears. Is this a bug or am I overlooking something?

Hmm, it appears you have a pretty similar setup to us here & we don’t seem to have the problem.
Has it just started, or since an upgrade or ?
It it only on some files, or all ?
Maybe it’s worth checking for a graphic-card driver update ?

I just started really using SketchUp maybe 3 weeks ago now and it’s been happening the entire time. There was an update to my graphics card I’m downloading now. I’ll see if this fixed it.

1 Like

The latest version of SketchUp for Windows is 23.1.340.

I suggest using the offline installer.
If you’ve run SketchUp this session, reboot machine before running installer.
When running installer, right-click it and choose “Run as administrator.”

If you’ve already updated, repeat the above, but choose the Repair option from the installer main page.

The issue is still happening after updating my graphics card. @DanRathbun thank you for advice. Looks like I’m not using the latest version. How do I use the offline installer?

I explained how to use it above. Download it from:

Maybe I asked the wrong question. Where is the offline installer located? I can see where to download the file from and your instructions for how to use it, but I don’t know what the “offline installer” is.

You can get the offline installer from this page:


The installer will download into your Downloads folder, and be named “SketchUpStudioFull-2023-1-340-117.exe”

The regular installer doesn’t include things such as language packs. If you chose to add other languages, those would be downloaded from a web site. Which means you would have to be online.

The offline installer includes all of the language packs. It’s a lot bigger file, but at least you don’t have to be online when installing extra languages. It’s sometimes a safer option, if you may be having network issues that cause problems when downloading the extra language files.


Also remember that SketchUp needs to be installed properly on a PC.
Close SketchUp/Layout if it’s open.
Find the installer’s exe file - as @colin described - in your Downloads folder.
Do NOT double-click its icon to ‘Run’ it.
But rather Select the exe file’s icon, right-click > context-menu > ‘Run as administrator’
When prompted choose ‘Install’, or if it’s already installed - ‘Repair’.
This will ensure that SketchUp is installed with all files and folders etc getting the correct permissions.
Even if you have admin powers, a simple ‘Run’ can result in unpredictable issues later…

1 Like

Thank you everyone for your help! Hopefully this solves the disappearing right-click menu but if not, I’ll be back :grin: