Ridiculously long time export Layout to pdf. Is this a Sonoma thing or a Layout thing...?

Hi folks, I’ve got a 55MB model, black and white ‘style’ rendered scenes with shadows, no materials.
I had created a 26 page Layout file of plans and scenes, raster images, no vector or hybrid rendering, which was hanging when trying to export to pdf.

Forced it to quit several times and tried again, no joy. 10 minutes watching a spinning beachball.

Restarted my Mac (Brand new M2 Max Mac Studio, 32GB unified RAM)

Split in to five 5 page files thinking that would speed things up.
Each apparently 55MB, not sure how a 5 page black & white layout file gets to 55MB but it is.

It’s just taken 13 minutes to export the first 5 A3 pages, two of which are just text, and 7 minutes for the second 5 pager.

I know exporting from Layout is seemingly never quick but this is crazy.
Any ideas?!
Go back to Ventura?

Happy to share the skp and Layout files if it will help.

Cheers

Have you updated to the most recent version recently? Layout is now set to convert to vector on export. You can turn this off in preferences.

2 Likes

The newest update to SketchUp introduced a new feature that allows the user to override the render method of raster rendered viewports for export. The feature is on by default and exports everytyhing hybrid-rendered. This is a lot slower than raster rendering for geometry-intensive models. You can turn it off in the Document Setup>Rendering dialog
image

3 Likes

Hi, thanks for the quick replies. And yes, installed 2023 when I set up my new computer and had not read about this feature, so that could well be it couldn’t it.

When it finishes exporting 5page file no 3 (10mins so far!) I’ll look in to that and turn it off!

Thanks!

1 Like

YEP! Override unchecked has sorted it. Thank you both again.

The file that took 13 minutes to export before just exported in a minute or so.

Pretty crazy that that is on as a default setting though right? If I wasn’t a poster here I would have had no idea!

Would be interesting for you to compare the quality of the export that took a long time, especially if you zoom into the PDF a lot.

That aside, we will change the default setting in an update. Can’t tell you when that will be.

3 Likes

Sounds like a good move!

1 Like

Hi Colin, the line quality is obviously great in the Hybrid Override Output version especially any diagonals, however, the style I use at this stage for these sketchy b&w shaded images has quite a big line extension setting (6) which is ok in Raster output mode, but the Hybrid mode has the line extension render far longer than it appears in the working model scene image and actually makes for a worse exported image.

Obviously if I know that I can reduce the extension setting for a hybrid output, but then my in model version doesn’t appear with any extension. These three screenshots show the differences…

This is a screenshot of a 3d plan scene in SketchUp (with Edit Resolution set to High - It turns out I had been in that settings window when i noticed the edit resolution of my logo image in Layout being reduced, but hadn’t noticed the Override thing) :

This is the Raster export which actually shows less line extension:

And then this is the Hybrid export with crazy line extension that spoils the image:

Same with views:

Model scene screenshot:

Raster output:

Hybrid output:

3 Likes

Hello all, is there a solution to this. It takes forever to export pdf in Layout. And I am on a M2 Mac

Yes there is. Read this thread.

2 Likes

This does not help:

The feature is on by default and exports everything hybrid-rendered. This is a lot slower than raster rendering for geometry-intensive models. You can turn it off in the Document Setup>Rendering dialog

My export is stuck since Sonoma Update!

It absolutely does help, and work, but you’re going to have to force-quit whatever is stuck trying to export and un-check the override setting so that you can export the raster rendered version.

My export that was taking 15 minutes took only a couple withthe override switched off.

It seems it’s not Sonoma, but the Layout 2023 update with the new render override default.

And, a new update to SketchUp 2023.1 was released yesterday with a bunch of bug fixes and small changes. This is one of them: Output Override is no longer turned on by default for older LayOut documents.

1 Like

Excellent news!

Runs away to get update >>>>>>>

It seems to be the file itself. It is stuck but don’t know why.

Other files I can export. Never had that issue before

Share the LO file so we can see what you are working with and so we can try the export on a different machine to see if that makes a difference.

If you have saved the file with the previous 2023.1 release, then that file will continue to have the output override setting enabled. Only files that have not already been opened and saved in 2023.1 will have the output override disabled by default.

Additionally, if you create your own templates, you can choose to have the output override disabled when creating new documents.

Adam

1 Like