Retrieve my file


#1

Sketchup asked me to confirm my project with the same name which already existed. I had no option but to click yes as I could not get past that page. So when I went to my project page to opened up my project it was a new model and I had lost my project? When I tried to open the file a pink popup came up saying - THE FILE IS NOT ENABLED FOR VIEWER BASED ON THE PROJECT CONFIGURATION. TO ENABLE VIEWING CAPABILITY PLEASE CONNECT SUPPORT. The end result is SketchUp support recommended me to put in an enhancement request for SketchUp. See below the reply

Unfortunately the functionality to bring that file back is unavailable in the sketchup application. Due to files not being assimilated inside of Trimble connect we are going to be unable to bring that particular revision back due to the file not actually being stored in Connect. I would recommend putting in an enhancement request for SketchUp on this issue.


#2

Hi Carla,

Sorry for the slow reply. From your post but it sounds like you may have accidentally overwritten your file.

Here’s a potential route to recover the version of the file before this all happened.

Sign-in to Trimble Connect at connect.trimble.com. This is the service SketchUp uses to save your models and also create a version history.
Navigate to your file. It may be in the ‘SketchUp’ project folder, or another project if you’ve created another project.
Click the checkbox next the name of your file. Don’t click on the name itself. (This will show you that error message you quoted above) See the attached image below:
In the right-hand nav, click on the far right icon. This will show you a version history. Scan back to find a version of the file before your over-write disaster.
Click the ‘cloud download icon’. This will pull down the SKP file for your recovered file. From here, you can upload this file back into SketchUp for Web and either save it as a new file, or Save As to overwrite the blank file you are trying to recover.

This image should help!

Let me know if this helps you get back up and running!

Mark

PS No need to submit an enhancement request: we know this is a confusing problem to run into!


#3

Hi Mark,
YES!!! it worked. Thank you so much, I now have my project back. It seems I can only view my project in sketchUp, as when I go into my Trimble a/c, I see the following error-

(Assimilation Progress Error processing data for Viewer. Please contact [support ](https
Notify me when done)

Not sure what that means. Also, I have noticed that it takes so long to save my project and am very wary if I get disconnected that I will lose my project. Is this normal to take that long to save a file? Again…many thanks, Carla