Removing aspect ratio crop


#1

Some weird behaviour with the camera tools today. At some point the camera tool created possibly 100 tabs of the same scene !!!
Also even though cameras, watermarks etc have all been deleted from the file, the camera crop areas (16:9) persist in the file, and show up in layout. Cant seem to be rid of them. Tried saving as another file, shut down and reopened etc???

Will probably have to cut and past the model from one file to another if all else fails?


#2

here’s the image


#3

Copy and paste this snippet into the Ruby Console and press Enter

Sketchup.active_model.active_view.camera.aspect_ratio=0.0


#4

Thanks George that worked.
Meanwhile, I had to go the long way around and copy and paste model into new file just to meet a deadline, but I checked this in the other file. Who’d of thought. Is this a bug of just a randomly corrupted file that needed a reset? I use the camera tools often but they always seem to have problems. Thanks so much, appreciate your insight. Any idea what was going on that so many camera views were created (literally 50 - 100)!