Removing all faces - but not lines?


Whats the best way to remove all faces in a structure?

I have a structure with many lines bisecting it - leading to many surplus faces when constructing it

How do I easily remove all the faces - keeping the lines? (without it doing it manually - selecting each face and deleting)

Alternatively is there a setting that will stop faces being created when intersecting a shape with lines?


I would recommend using Selection Toys. With it, you can select all, right click, choose Select Only… Faces, then press Delete.

Without recourse to plugins, you can uncheck (turn off) Edges and Profiles on the Edge Settings dialog, whereupon you can select all and hit Delete, getting rid of all faces. When you recheck Edges and Profiles, there they will be.



Or with SketchUp’s native tools:

  • switch to style 'Wireframe
  • select all by dragging a selection window around the model
  • switch to style ‘Shaded (with textures)’ or ‘Monochrome’ to see edges AND faces
  • deselect the edges from the selection while selecting the faces by dragging the selection window around the geometry
  • (only faces should be selected now) hit ‘Delete’.

This works for faces in the current context. Do not include groups and/or components in the selection.

(@Gully_Foyle, I was doing it the “hard” way)

Been there lots of times.


These are absolutely options… but I do recommend getting Selection Toys, As it is a very useful set of tools.

If it’s that useful, why isn’t it incorporated into the native program? Aaron, it seems to me that as a SketchUp Team member you should be first in line to suggest a native solution.


1 Like

I am all for using native tools, but if there is a better way out there that I, personally, believe in, then i suggest it!

As for getting it into SketchUp… That is a bit outside of my job description…

1 Like

Group the geometry that you wish to protect. Window select it, right-click the selection, choose “Make Group”.