Rectangle button not producing 90 degree corners


#1

So, if I draw lines, I can draw them along the proper axes, no problem. But in this particular drawing, using the rectangle command produces corners that do not line up on both x and y axes. In the attached example, my edges are set to be colored “by axis” to show the problem.


SU_zoom

Anyone know what is causing this? and how to fix it?
Thanks.


#2

you could try to “reset” axes - right click on any of the axis lines and click reset? if it’s grayed out it is OK and doesn’t need to be reset but if “reset” is black it might need to be reset?


#3

Thanks, that worked.

But I had changed my axes earlier. So now they are back to the original location/direction. I guess I can work with it for now. I’ve never had this issue when modifying the axes before, though. There may be models in the future that require me to change the x/y axes. Don’t want to run into this again.


#4

Depending on how you altered the drawing axes, some may still be parallel to the originals while others may be askew. That will affect which previously-drawn edges still get color-by-axis. Also, be aware that because color-by-axis works to within a tolerance it is not a reliable way to detect tiny misalignments. An edge colored red can actually be misaligned by a small amount!


#5

Good to know, thanks!


#6

Hi Steve, I wonder what you mean by that. ‘Color by Axes’ (although within tolerance) is always ‘Color by current drawing Axes’

End the (changed) drawing axes are always 90° (unless manipulated like in a group or component)

It’s still a mystery why/how a rectangle produces on axis plus black edges in the same operation.

While writing this I now have a hunch. It’s always the smallest edges that may be black, the largest edges are either red, green or blue. But the corners are 90°, unlike what the OP is telling. Probably when the altered drawing axes are close to the systems axes.


#7

Yes, the color-by-axis is always in terms of the current drawing axes. But you can change the drawing axes, for example by rotating around red, so that one of them is still parallel to the model axes. When you do that, edges that were originally drawn parallel to red will still be colored red, but ones that were drawn parallel to green or blue will go black. I wasn’t sure whether new rectangles or previously drawn ones were affected.

You may be right that when the drawing axes are close but not quite on the model axes the problem appears. I haven’t been able to make it happen for new rectangles, so I don’t know. I suppose it would be useful if the OP could post a sample file that exhibits the problem, not just an image.


#8

D’oh, how could I miss that, rotating around one of the rectangles edges. Don’t tell anyone.

My hunch is actually based on something else I experienced in the past, the oppossite of what I wrote:
Short edges can be colored by axis while when making them longer in the same direction, they turn black, exceeding the tolerance value.


#9

Yeah, I think that SketchUp determines “parallel to axis” by calculating the change in the x, y, or z coordinate along an edge and comparing the value to a threshold. When you extend an edge, the change grows proportionally to the length.


#10

Also, while that reset sets the global axes, it is still possible to set the axes as you want on a per scene basis. If you update/save a scene having changed the scene’s axes, those axes settings will be there when you return to that scene.