Recover parts of “Unexpected file format”

Hi

I am a victim of the “Unexpected File Format” error, even the backup file is corrupted. The weird thing is that the thumbnail works perfectly

I have read that @colin can help restoring some components. I would appreciate if so
Thank you so so much!

Here are the files (original, back up):
Escritorio.skp (262.5 KB)
EscritorioBackUp.skp (255.5 KB)

Unfortunately, I could get almost nothing from either file.

Hi @colin I have the same problem with my file. I already tried other applications, even imported it in AutoCAD but it won’t read the file. It is an autosave file which I copied in my old unit and I could not find the original file. Is there any way that the content be recovered?

Here is the link of my file: Dropbox - AutoSave_NANANA.skp - Simplify your life

Hope you could help.
Thank you!

There is nothing in the scene, but most of the file size is recovered. Hopefully you had some components that included large areas of the scene.

Hi, @colin. Thank you so much for your help! I apologize for that. It’s weird because there is an image of the project in the icon. I tried to reupload the file. Hopefully, you could recheck it: Dropbox - SketchUp - Simplify your life

Again, thank you so much.

There was something you misunderstood. I was saying that in my recovered version there is nothing in the scene, that’s because I could only recover the components and materials, and couldn’t recover the model scene content. I’m sure that your original file does have content in the scene.

So, from the recovered file I gave you, you would look through the Components panel to hopefully find large chunks of the scene. You then would rebuild the scene by moving the bigger components back into the right place.

The thumbnail image for the file is only an image, it isn’t a render of the current state of the file, though in a normal file it would look like it is.