Re: 2D Floor Plan


#1

Hello All. I am new to the forum and new to Sketchup.

I am using SketchUp primarily for drawing interiors for the purpose of interior design (for personal projects, not professionally). I am fairly comfortable with 3D drawing but I am stuck on what should be a simple 2D floor plan.

I would like to use SketchUp to play with various furniture arrangements in a room (all on a flat 2D drawing).

I have a drawing of the floor space and shapes representing furniture pieces (in the analog world this would be the equivalent of move cut out pieces of construction paper around on a sheet of graph paper).

When I overlay a furniture piece on the floor, the two pieces merge. This makes sense being that they exist on the same plan and have now thickness.

Can anyone recommend a better approach? Can the top surface of the floor and the bottom surface of the furniture cutouts be “magnetic” so that they cling together but do not merge?

Any advice is appreciated. Thank you.


#2
  • If all I wanted was a 2D drawing, I probably wouldn’t use a 3D modeling app to make it.

  • If you place raw geometry in a group or component, it won’t stick to things.

  • If you learn to use the Move tool properly, you don’t need for things to be “magnetic.” You just put them where the’re supposed to go and they stay there until you move them. If you don’t know how to use the Move tool and would rather not learn (for some reason), you can give components a “glue to” property, which is similar to your “magnetic” effect, but stronger. However, that’s something else you would need to learn.

-Gully


#3

Create your 2D floor plan then make it a group. Now you can freely place your furniture components where you want and move them about as needed.


#4

@rfimbel To expand on what Gully mentioned, components with the property ‘Glue to’ will stick to the plane of a single face if you set them up right. But also make them (the pieces of furniture) components with the property ‘Cut opening’ in the face they are put on.
In your case I would even consider exporting the floor plan geometry as 2D graphic… (*.jpg or *.png) to optain an image that can be imported again and to apply to a single face. This way you aren’t hindered by any edges splitting up any room. You deal with just one face.
Read about components and how to create them properly.
You can shift furniture around as you like without z-fighting, i.e. two faces showing at the same location.


#5

Thank you everyone for the replies.

I made all the furniture components into with “Glue To” set to Horizontal and the “Cut Opening” enabled.

This works well as long as I am viewing from the Top (this is really all I need). If I switch to an ISO view, the furniture shapes do not render correctly (see images below).

Perhaps this is a rendering problem related to the video card / computer resources? (working on a 2007 iMac).


#6

You applied the cut opening function incorrectly. The whole point of cut opening is to avoid having two contrasting faces occupy the same space, creating z-fighting errors. Z-fighting is when SU can’t decide which of two faces is in front, so it displays both of them in a sort of nasty, flickery way. If you remove one of the faces–no z-fighting.

Take another look at the instructions and keep trying until you get it. It’s usually easiest if you create the cut opening component in situ.

-Gully


#7

Gully,

Thank you. I know what I was doing wrong.

The floor was in a group. I needed to either explode this group to add the furniture components or click double click to get inside the group.

Its all working as expected now.